summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2009-10-02 22:12:19 +0000
committerLance Albertson <ramereth@gentoo.org>2009-10-02 22:12:19 +0000
commitec9529d1d210cf1a33c419834baea612b4a43d27 (patch)
tree7154e73129902c412b0e9610f36931c621c958e5 /app-emulation/ganeti
parentAdd new revision to ensure that dev-python/sip is installed by default for Py... (diff)
downloadgentoo-2-ec9529d1d210cf1a33c419834baea612b4a43d27.tar.gz
gentoo-2-ec9529d1d210cf1a33c419834baea612b4a43d27.tar.bz2
gentoo-2-ec9529d1d210cf1a33c419834baea612b4a43d27.zip
Version bump to 2.x
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog13
-rw-r--r--app-emulation/ganeti/files/ganeti-2.0.3-gentoo-brctl-path.patch12
-rw-r--r--app-emulation/ganeti/files/ganeti2.initd55
-rw-r--r--app-emulation/ganeti/ganeti-2.0.3.ebuild66
-rw-r--r--app-emulation/ganeti/ganeti-2.0.4.ebuild66
-rw-r--r--app-emulation/ganeti/metadata.xml28
6 files changed, 235 insertions, 5 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 9921622e6f3c..d729d42f8b82 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.9 2009/09/24 18:44:09 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.10 2009/10/02 22:12:18 ramereth Exp $
+
+*ganeti-2.0.4 (02 Oct 2009)
+*ganeti-2.0.3 (02 Oct 2009)
+
+ 02 Oct 2009; Lance Albertson <ramereth@gentoo.org>
+ +files/ganeti-2.0.3-gentoo-brctl-path.patch, +ganeti-2.0.4.ebuild,
+ +files/ganeti2.initd, +ganeti-2.0.3.ebuild, metadata.xml:
+ Version bump to 2.x
+
+ Special thanks to Russell Haering <russell_h@osuosl.org>, and Ben Kero
+ <bkero@osuosl.org> for contributing to the ebuild.
24 Sep 2009; Lance Albertson <ramereth@gentoo.org> metadata.xml:
Set myself as the new maintainer, 2.x ebuilds forthcoming soon...
diff --git a/app-emulation/ganeti/files/ganeti-2.0.3-gentoo-brctl-path.patch b/app-emulation/ganeti/files/ganeti-2.0.3-gentoo-brctl-path.patch
new file mode 100644
index 000000000000..461a97876d95
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti-2.0.3-gentoo-brctl-path.patch
@@ -0,0 +1,12 @@
+diff -ruN work.orig/ganeti-2.0.3/lib/hypervisor/hv_kvm.py work/ganeti-2.0.3/lib/hypervisor/hv_kvm.py
+--- a/ganeti-2.0.3/lib/hypervisor/hv_kvm.py 2009-09-23 09:56:34.000000000 -0700
++++ b/ganeti-2.0.3/lib/hypervisor/hv_kvm.py 2009-09-23 09:56:50.000000000 -0700
+@@ -137,7 +137,7 @@
+ script.write("else\n")
+ script.write(" # Connect the interface to the bridge\n")
+ script.write(" /sbin/ifconfig $INTERFACE 0.0.0.0 up\n")
+- script.write(" /usr/sbin/brctl addif $BRIDGE $INTERFACE\n")
++ script.write(" /sbin/brctl addif $BRIDGE $INTERFACE\n")
+ script.write("fi\n\n")
+ # As much as we'd like to put this in our _ROOT_DIR, that will happen to be
+ # mounted noexec sometimes, so we'll have to find another place.
diff --git a/app-emulation/ganeti/files/ganeti2.initd b/app-emulation/ganeti/files/ganeti2.initd
new file mode 100644
index 000000000000..924f7e60eb4d
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti2.initd
@@ -0,0 +1,55 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/files/ganeti2.initd,v 1.1 2009/10/02 22:12:19 ramereth Exp $
+
+depend() {
+ need localmount drbd
+ after bootmisc
+}
+
+checkconfig() {
+ for fname in /var/lib/ganeti/server.pem
+ do
+ if [[ ! -f "$fname" ]]
+ then
+ eerror "Config file $fname not found, will not run."
+ return 1
+ fi
+ done
+
+ return 0
+}
+
+start_action() {
+ # called as start_action daemon pidfile
+ local daemon="${1}"; shift
+ local pidfile="${1}"; shift
+ ebegin "Starting ${daemon}"
+ start-stop-daemon --start --quiet --exec "${daemon}" --pidfile "${pidfile}" \
+ -- "${@}"
+ eend ${?}
+}
+
+stop_action() {
+ # called as stop_action daemon pidfile
+ ebegin "Stopping ${1}"
+ start-stop-daemon --stop --quiet --oknodo --retry 30 --pidfile "${2}"
+ eend ${?}
+}
+
+
+start() {
+ checkconfig || return 1
+ start_action /usr/sbin/ganeti-noded /var/run/ganeti/ganeti-noded.pid
+ start_action /usr/sbin/ganeti-masterd /var/run/ganeti/ganeti-masterd.pid
+ start_action /usr/sbin/ganeti-rapi /var/run/ganeti/ganeti-rapi.pid
+ return 0
+}
+
+stop() {
+ stop_action /usr/sbin/ganeti-rapi /var/run/ganeti/ganeti-rapi.pid
+ stop_action /usr/sbin/ganeti-masterd /var/run/ganeti/ganeti-masterd.pid
+ stop_action /usr/sbin/ganeti-noded /var/run/ganeti/ganeti-noded.pid
+ return 0
+}
diff --git a/app-emulation/ganeti/ganeti-2.0.3.ebuild b/app-emulation/ganeti/ganeti-2.0.3.ebuild
new file mode 100644
index 000000000000..01a1c1c4734e
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.0.3.ebuild,v 1.1 2009/10/02 22:12:18 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+src_prepare () {
+ epatch "${FILESDIR}/${P}-gentoo-brctl-path.patch"
+}
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ --with-file-storage-dir=/var/lib/ganeti-storage/file
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti2.initd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc DEVNOTES INSTALL NEWS README doc/*.rst doc/*.txt
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/dumb-allocator doc/examples/ganeti.cron
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}
diff --git a/app-emulation/ganeti/ganeti-2.0.4.ebuild b/app-emulation/ganeti/ganeti-2.0.4.ebuild
new file mode 100644
index 000000000000..6b2adc2ea352
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.0.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.0.4.ebuild,v 1.1 2009/10/02 22:12:18 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-2.0.3-gentoo-brctl-path.patch"
+}
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ --with-file-storage-dir=/var/lib/ganeti-storage/file
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti2.initd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc DEVNOTES INSTALL NEWS README doc/*.rst doc/*.txt
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/dumb-allocator doc/examples/ganeti.cron
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}
diff --git a/app-emulation/ganeti/metadata.xml b/app-emulation/ganeti/metadata.xml
index 5d121780533e..3d6ff6e967aa 100644
--- a/app-emulation/ganeti/metadata.xml
+++ b/app-emulation/ganeti/metadata.xml
@@ -1,9 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
+ <herd>virtualization</herd>
+ <maintainer>
<email>ramereth@gentoo.org</email>
- <description>Lance Albertson</description>
- </maintainer>
+ <name>Lance Albertson</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ganeti is a cluster virtual server management software tool built on top of
+ existing virtualization technologies such as Xen or KVM and other Open
+ Source software.
+
+ Ganeti requires pre-installed virtualization software on your servers in
+ order to function. Once installed, the tool will take over the management
+ part of the virtual instances (Xen DomU), e.g. disk creation management,
+ operating system installation for these instances (in co-operation with
+ OS-specific install scripts), and startup, shutdown, failover between
+ physical systems. It has been designed to facilitate cluster management of
+ virtual servers and to provide fast and simple recovery after physical
+ failures using commodity hardware.
+ </longdescription>
+ <use>
+ <flag name='kvm'>Enable KVM support</flag>
+ <flag name='xen'>Enable Xen support</flag>
+ <flag name='drbd'>Enable DRBD support</flag>
+ </use>
</pkgmetadata>
+