summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2007-11-18 05:38:01 +0000
committerMike Doty <kingtaco@gentoo.org>2007-11-18 05:38:01 +0000
commite719f3b595d2b0c85f001daf9863e9e2f2a12689 (patch)
tree61d8b1519cd7c97e0480dedabc7b1707cc37bb47 /app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild
parentBuild gd-based helper tools when USE=gd #198381. (diff)
downloadgentoo-2-e719f3b595d2b0c85f001daf9863e9e2f2a12689.tar.gz
gentoo-2-e719f3b595d2b0c85f001daf9863e9e2f2a12689.tar.bz2
gentoo-2-e719f3b595d2b0c85f001daf9863e9e2f2a12689.zip
fixed lib32 dirname bug
(Portage version: 2.1.3.17)
Diffstat (limited to 'app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild')
-rw-r--r--app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild b/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild
new file mode 100644
index 000000000000..b00400490b92
--- /dev/null
+++ b/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-20071118.ebuild,v 1.1 2007/11/18 05:38:00 kingtaco Exp $
+
+inherit emul-linux-x86
+
+LICENSE="|| ( Artistic GPL-2 ) || ( BSD GPL-2 ) BZIP2 CRACKLIB DB
+ GPL-2 || ( GPL-2 AFL-2.1 ) LGPL-2 LGPL-2.1 MIT OPENLDAP openssl
+ PAM ZLIB as-is"
+KEYWORDS="-* ~amd64"
+
+DEPEND=""
+RDEPEND="!<app-emulation/emul-linux-x86-medialibs-10.2" # bug 168507
+
+src_unpack() {
+ export ALLOWED="(${S}/lib32/security/pam_filter/upperLOWER|${S}/etc/env.d)"
+ emul-linux-x86_src_unpack
+ rm -rf "${S}/etc/env.d/binutils/" \
+ "${S}/usr/lib32/binutils/" \
+ "${S}/usr/lib32/engines/" \
+ "${S}/usr/lib32/openldap/" \
+ "${S}/usr/lib32/python2.4/"
+
+ ln -s ../share/terminfo "${S}/usr/lib32/terminfo"
+}