summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 19:00:34 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 19:00:34 +0000
commit7df6ed9027344368bc79a26769fcd7e7edc1d8db (patch)
tree4a559fa523c1805c654315be10989bb895765685 /app-emulation/dlx
parentQA: Respect AR/CC/RANLIB (bug 243576) (diff)
downloadgentoo-2-7df6ed9027344368bc79a26769fcd7e7edc1d8db.tar.gz
gentoo-2-7df6ed9027344368bc79a26769fcd7e7edc1d8db.tar.bz2
gentoo-2-7df6ed9027344368bc79a26769fcd7e7edc1d8db.zip
QA: Respect CC (bug 243578) and CFLAGS/LDFLAGS (bug 240003)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-emulation/dlx')
-rw-r--r--app-emulation/dlx/ChangeLog5
-rw-r--r--app-emulation/dlx/dlx-1.0.0-r1.ebuild18
2 files changed, 16 insertions, 7 deletions
diff --git a/app-emulation/dlx/ChangeLog b/app-emulation/dlx/ChangeLog
index f41d4808acf6..9fe04a46aff6 100644
--- a/app-emulation/dlx/ChangeLog
+++ b/app-emulation/dlx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/dlx
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dlx/ChangeLog,v 1.9 2008/04/21 16:43:32 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dlx/ChangeLog,v 1.10 2008/12/30 19:00:34 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> dlx-1.0.0-r1.ebuild:
+ QA: Respect CC (bug 243578) and CFLAGS/LDFLAGS (bug 240003)
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-emulation/dlx/dlx-1.0.0-r1.ebuild b/app-emulation/dlx/dlx-1.0.0-r1.ebuild
index 813fd8d9fb27..31bf466d2c34 100644
--- a/app-emulation/dlx/dlx-1.0.0-r1.ebuild
+++ b/app-emulation/dlx/dlx-1.0.0-r1.ebuild
@@ -1,20 +1,26 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dlx/dlx-1.0.0-r1.ebuild,v 1.2 2005/01/01 14:09:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dlx/dlx-1.0.0-r1.ebuild,v 1.3 2008/12/30 19:00:34 angelos Exp $
+
+inherit toolchain-funcs
-S=${WORKDIR}/dlx
DESCRIPTION="DLX Simulator"
HOMEPAGE="http://www.davidviner.com/dlx.php"
-SRC_URI="http://www.davidviner.com/dlx/dlx.tar.gz"
+SRC_URI="http://www.davidviner.com/${PN}/${PN}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
-DEPEND=""
+
+S="${WORKDIR}/${PN}"
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" \
+ LINK="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ || die "emake failed"
}
src_install() {