summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-23 18:11:03 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-23 18:11:03 +0000
commita1bf4a566dd604ba899d4f4160a625e4f1ae9587 (patch)
tree345dce08f95623b7afe4b3a37ac085805618126c /app-emulation/crossover-office-bin
parentCheck that pinentry was merged with USE=gtk or USE=qt3 (bug #170967) (diff)
downloadgentoo-2-a1bf4a566dd604ba899d4f4160a625e4f1ae9587.tar.gz
gentoo-2-a1bf4a566dd604ba899d4f4160a625e4f1ae9587.tar.bz2
gentoo-2-a1bf4a566dd604ba899d4f4160a625e4f1ae9587.zip
Version bump #176357 by Maxwell Grender-Jones.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'app-emulation/crossover-office-bin')
-rw-r--r--app-emulation/crossover-office-bin/ChangeLog8
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild50
-rw-r--r--app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.0.12
3 files changed, 59 insertions, 1 deletions
diff --git a/app-emulation/crossover-office-bin/ChangeLog b/app-emulation/crossover-office-bin/ChangeLog
index 63f2fdc4a78f..3d4cbe18523d 100644
--- a/app-emulation/crossover-office-bin/ChangeLog
+++ b/app-emulation/crossover-office-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/crossover-office-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/ChangeLog,v 1.12 2007/01/21 18:19:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/ChangeLog,v 1.13 2007/06/23 18:11:02 vapier Exp $
+
+*crossover-office-bin-6.0.1 (23 Jun 2007)
+
+ 23 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +crossover-office-bin-6.0.1.ebuild:
+ Version bump #176357 by Maxwell Grender-Jones.
*crossover-office-bin-6.0.0 (21 Jan 2007)
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
new file mode 100644
index 000000000000..cc337017d95d
--- /dev/null
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild,v 1.1 2007/06/23 18:11:02 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-standard-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="nas"
+RESTRICT="fetch nostrip"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ dev-util/desktop-file-utils
+ nas? ( media-libs/nas )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}
+
+pkg_postinst() {
+ einfo "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ einfo "bottles and install Windows applications."
+}
diff --git a/app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.0.1 b/app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.0.1
new file mode 100644
index 000000000000..1012212404c7
--- /dev/null
+++ b/app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.0.1
@@ -0,0 +1,2 @@
+RMD160 5159c223b6c9160ec82e91b18345d0b3fbc46e2f install-crossover-standard-6.0.1.sh 20097976
+SHA256 cc77a25d46f09b357b7d0ecb86c6749db052bc91622d291a18732aa3803894e2 install-crossover-standard-6.0.1.sh 20097976