summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-03-27 13:57:50 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-03-27 13:57:50 +0000
commitcca4565d06c96e72fd91703c68597a394d0e6fdd (patch)
tree98100f2c2bf88f3ea95ee3f69b8625eaf251f20f /app-emacs
parentadd explicit dep on gettext in case it leaves the system profiles (diff)
downloadgentoo-2-cca4565d06c96e72fd91703c68597a394d0e6fdd.tar.gz
gentoo-2-cca4565d06c96e72fd91703c68597a394d0e6fdd.tar.bz2
gentoo-2-cca4565d06c96e72fd91703c68597a394d0e6fdd.zip
Version bump.
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yc/ChangeLog14
-rw-r--r--app-emacs/yc/files/digest-yc-3.5.11
-rw-r--r--app-emacs/yc/yc-3.5.1.ebuild50
3 files changed, 61 insertions, 4 deletions
diff --git a/app-emacs/yc/ChangeLog b/app-emacs/yc/ChangeLog
index e244e9fc4a9a..80ae4c72f829 100644
--- a/app-emacs/yc/ChangeLog
+++ b/app-emacs/yc/ChangeLog
@@ -1,17 +1,23 @@
# ChangeLog for app-emacs/yc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.3 2003/02/12 03:58:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.4 2003/03/27 13:57:50 nakano Exp $
+
+*yc-3.5.1 (27 Mar 2003)
+
+ 27 Mar 2003; Masatomo Nakano <nakano@gentoo.org> ChangeLog, yc-3.5.1.ebuild:
+
+ Version bump.
*yc-3.5.0 (20 Dec 2002)
24 Dec 2002; Masatomo Nakano <nakano@gentoo.org> ChangeLog,
- yc-3.5.0.ebuild
+ yc-3.5.0.ebuild:
- Changed Keywords from ~x86 to x86.
+ Changed Keywords from ~x86 to x86.
20 Dec 2002; Masatomo Nakano <nakano@gentoo.org> ChangeLog,
yc-3.5.0.ebuild, files/30yc-gentoo.el, files/sample.dot.emacs,
- files/sample.hosts.canna, files/digest-yc-3.5.0 :
+ files/sample.hosts.canna, files/digest-yc-3.5.0 :
Initial import. Ebuild submitted by ni_naoto@ybb.ne.jp (Nishimura Naoto).
diff --git a/app-emacs/yc/files/digest-yc-3.5.1 b/app-emacs/yc/files/digest-yc-3.5.1
new file mode 100644
index 000000000000..8456c1ed10a2
--- /dev/null
+++ b/app-emacs/yc/files/digest-yc-3.5.1
@@ -0,0 +1 @@
+MD5 52bb46bfddb083ecc98cdbf0e2f281b7 yc.el-3.5.1.gz 32342
diff --git a/app-emacs/yc/yc-3.5.1.ebuild b/app-emacs/yc/yc-3.5.1.ebuild
new file mode 100644
index 000000000000..492072e33ab0
--- /dev/null
+++ b/app-emacs/yc/yc-3.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/yc-3.5.1.ebuild,v 1.1 2003/03/27 13:57:50 nakano Exp $
+
+inherit elisp
+
+IUSE=""
+
+MY_P=yc.el-${PV}
+DESCRIPTION="YC - Yet another Canna client on Emacsen."
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${MY_P}.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ >=app-i18n/canna-3.5_beta2"
+
+S="${WORKDIR}/${P}"
+SITEFILE="50yc-gentoo.el"
+
+src_unpack() {
+ mkdir -p ${S}
+ gzip -dc ${DISTDIR}/${MY_P}.gz > ${S}/yc.el
+}
+
+src_compile() {
+ emacs -batch -eval '(byte-compile-file "yc.el")'
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ${FILESDIR}/sample*
+}
+
+pkg_postinst() {
+ einfo "Please modify as following in /etc/conf.d/canna."
+ einfo "\n\t CANNASERVER_OPTS=\"-inet\"\n"
+ einfo "And create /etc/hosts.canna."
+ einfo "(sample is /usr/share/doc/${P}/sample.hosts.canna.gz)"
+ einfo "And see /usr/share/doc/${P}/sample.dot.emacs.gz."
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}