summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-09-25 21:18:36 +0000
committerUlrich Müller <ulm@gentoo.org>2012-09-25 21:18:36 +0000
commit9bb32dde9b7976ec46fb9b0a58acdeaf30a290c4 (patch)
tree78e99709cd1fdd5fb40173521450436674b9f27b /app-emacs
parentAdd license for app-emacs/mpg123-el. (diff)
downloadgentoo-2-9bb32dde9b7976ec46fb9b0a58acdeaf30a290c4.tar.gz
gentoo-2-9bb32dde9b7976ec46fb9b0a58acdeaf30a290c4.tar.bz2
gentoo-2-9bb32dde9b7976ec46fb9b0a58acdeaf30a290c4.zip
Version bump. Update LICENSE.
(Portage version: 2.1.11.20/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/mpg123-el/ChangeLog10
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.55.ebuild6
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.58.ebuild38
3 files changed, 49 insertions, 5 deletions
diff --git a/app-emacs/mpg123-el/ChangeLog b/app-emacs/mpg123-el/ChangeLog
index 38c04d20c790..80f8f7b23530 100644
--- a/app-emacs/mpg123-el/ChangeLog
+++ b/app-emacs/mpg123-el/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/mpg123-el
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/ChangeLog,v 1.32 2010/10/15 08:30:15 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/ChangeLog,v 1.33 2012/09/25 21:18:36 ulm Exp $
+
+*mpg123-el-1.58 (25 Sep 2012)
+
+ 25 Sep 2012; Ulrich Müller <ulm@gentoo.org> mpg123-el-1.55.ebuild,
+ +mpg123-el-1.58.ebuild:
+ Version bump. Update LICENSE.
15 Oct 2010; Christian Faulhammer <fauli@gentoo.org>
-mpg123-el-1.52.ebuild:
diff --git a/app-emacs/mpg123-el/mpg123-el-1.55.ebuild b/app-emacs/mpg123-el/mpg123-el-1.55.ebuild
index af09f39c468a..7b259a1666f6 100644
--- a/app-emacs/mpg123-el/mpg123-el-1.55.ebuild
+++ b/app-emacs/mpg123-el/mpg123-el-1.55.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.55.ebuild,v 1.6 2010/10/14 16:47:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.55.ebuild,v 1.7 2012/09/25 21:18:36 ulm Exp $
inherit elisp toolchain-funcs
@@ -8,7 +8,7 @@ DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="as-is"
+LICENSE="mpg123-el"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="vorbis"
diff --git a/app-emacs/mpg123-el/mpg123-el-1.58.ebuild b/app-emacs/mpg123-el/mpg123-el-1.58.ebuild
new file mode 100644
index 000000000000..09f72a79f0cd
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.58.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.58.ebuild,v 1.1 2012/09/25 21:18:36 ulm Exp $
+
+EAPI=4
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="mpg123-el"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis"
+
+RDEPEND="media-sound/mpg123
+ media-sound/alsa-utils
+ vorbis? ( media-sound/vorbis-tools )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ dobin tagput id3put
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}