summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-01 16:10:11 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-01 16:10:11 +0000
commit8084a8d19970f602e057f63d5b2c52f246e9dd22 (patch)
treede467f325573cfab81bc902234adc7210ead15c5 /app-emacs
parentSet LICENSE to Kannel. (diff)
downloadgentoo-2-8084a8d19970f602e057f63d5b2c52f246e9dd22.tar.gz
gentoo-2-8084a8d19970f602e057f63d5b2c52f246e9dd22.tar.bz2
gentoo-2-8084a8d19970f602e057f63d5b2c52f246e9dd22.zip
Replace basename and dirname by their shell equivalents.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cedet/cedet-1.0_pre6.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-emacs/cedet/cedet-1.0_pre6.ebuild b/app-emacs/cedet/cedet-1.0_pre6.ebuild
index 221a21454fb5..4f4c42aeef36 100644
--- a/app-emacs/cedet/cedet-1.0_pre6.ebuild
+++ b/app-emacs/cedet/cedet-1.0_pre6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre6.ebuild,v 1.1 2009/03/01 15:38:25 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre6.ebuild,v 1.2 2009/03/01 16:10:11 ulm Exp $
NEED_EMACS=22
@@ -33,30 +33,31 @@ src_test() {
}
src_install() {
+ local target file dir
find . -type d -name tests -prune -o -type f -print | while read target
do
- local directory=$(dirname ${target}) file=$(basename ${target})
- local sub_directory=$(echo ${directory} | sed "s%^${S}/*%%;s/^$/./")
- case $file in
+ file=${target##*/}
+ dir=${target%/*}; dir=${dir#./}
+ case "${file}" in
*~ | Makefile | *.texi | *-script | PRERELEASE_CHECKLIST \
| Project.ede | USING_CEDET_FROM_CVS | grammar-fw-ov.txt)
;;
ChangeLog | README | AUTHORS | *NEWS | INSTALL \
| renamelist.txt | semanticdb.sh)
- docinto ${sub_directory}
- dodoc ${target} || die ;;
+ docinto "${dir}"
+ dodoc "${target}" || die ;;
*.el | *.elc | *.by | *.wy)
# install grammar sources along with the elisp files, since
# the location where semantic expects them is not configurable
- insinto ${SITELISP}/${PN}/${sub_directory}
- doins ${target} || die ;;
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}" || die ;;
*.srt | *.xpm)
- insinto ${SITEETC}/${PN}/${sub_directory}
- doins ${target} || die ;;
+ insinto "${SITEETC}/${PN}/${dir}"
+ doins "${target}" || die ;;
*.info* | grammar-fw-ov.png)
- doinfo ${target} || die ;;
+ doinfo "${target}" || die ;;
*)
- die "Unrecognised file ${sub_directory}/${file}" ;;
+ die "Unrecognised file ${target}" ;;
esac
done