summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/semantic
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/semantic')
-rw-r--r--app-emacs/semantic/ChangeLog11
-rw-r--r--app-emacs/semantic/files/60semantic-gentoo.el4
-rw-r--r--app-emacs/semantic/files/digest-semantic-1.41
-rw-r--r--app-emacs/semantic/semantic-1.4.ebuild41
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/semantic/ChangeLog b/app-emacs/semantic/ChangeLog
new file mode 100644
index 000000000000..4ef1394e5370
--- /dev/null
+++ b/app-emacs/semantic/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/semantic
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semantic/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*semantic-1.4 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ semantic-1.4.ebuild, files/60semantic-gentoo.el,
+ files/digest-semantic-1.4 :
+
+ Initial import.
diff --git a/app-emacs/semantic/files/60semantic-gentoo.el b/app-emacs/semantic/files/60semantic-gentoo.el
new file mode 100644
index 000000000000..b4f64e0719e5
--- /dev/null
+++ b/app-emacs/semantic/files/60semantic-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; semantic site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
diff --git a/app-emacs/semantic/files/digest-semantic-1.4 b/app-emacs/semantic/files/digest-semantic-1.4
new file mode 100644
index 000000000000..adb681889359
--- /dev/null
+++ b/app-emacs/semantic/files/digest-semantic-1.4
@@ -0,0 +1 @@
+MD5 ee40483c0833e094ec160e7ee3d1b0e2 semantic-1.4.tar.gz 306591
diff --git a/app-emacs/semantic/semantic-1.4.ebuild b/app-emacs/semantic/semantic-1.4.ebuild
new file mode 100644
index 000000000000..fd1d2860b3ec
--- /dev/null
+++ b/app-emacs/semantic/semantic-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semantic/semantic-1.4.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Enhanced Integration of Emacs Interpreted Objects"
+HOMEPAGE="http://cedet.sourceforge.net/semantic.shtml"
+SRC_URI="mirror://sourceforge/cedet/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ app-emacs/speedbar
+ app-emacs/eieio"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ make LOADPATH="${SITELISP}/speedbar ${SITELISP}/eieio" || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.bnf
+ elisp-site-file-install ${FILESDIR}/60semantic-gentoo.el
+
+ dodoc ChangeLog NEWS INSTALL
+ doinfo semantic.info*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "See the /usr/share/doc/${P}/INSTALL.gz for tips on how to customize this package"
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}