summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-08 10:12:07 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-08 10:12:07 +0000
commit7a4648f1c9473dfe6f05d95a8a9de98852e2b86e (patch)
treeb99e966570cffd7818e7ce5baca52a3379130543 /app-emacs/python-mode
parentMaintenance release bump, shorten DESCRIPTION (diff)
downloadgentoo-2-7a4648f1c9473dfe6f05d95a8a9de98852e2b86e.tar.gz
gentoo-2-7a4648f1c9473dfe6f05d95a8a9de98852e2b86e.tar.bz2
gentoo-2-7a4648f1c9473dfe6f05d95a8a9de98852e2b86e.zip
Add pymacs USE flag wrt bug 208186.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog9
-rw-r--r--app-emacs/python-mode/python-mode-1.0-r1.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index d9c9fb3cfc3c..9f02ac6b04bf 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/python-mode
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.27 2007/10/06 20:31:20 ulm Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.28 2008/02/08 10:12:07 ulm Exp $
+
+*python-mode-1.0-r1 (08 Feb 2008)
+
+ 08 Feb 2008; Ulrich Mueller <ulm@gentoo.org> +python-mode-1.0-r1.ebuild:
+ Add pymacs USE flag wrt bug 208186.
06 Oct 2007; Ulrich Mueller <ulm@gentoo.org> python-mode-1.0.ebuild:
Minor QA: quote some variables. Drop ppc-macos keyword.
diff --git a/app-emacs/python-mode/python-mode-1.0-r1.ebuild b/app-emacs/python-mode/python-mode-1.0-r1.ebuild
new file mode 100644
index 000000000000..e7a20790c7ba
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-1.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-1.0-r1.ebuild,v 1.1 2008/02/08 10:12:07 ulm Exp $
+
+inherit elisp distutils
+
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="http://sourceforge.net/projects/python-mode/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd"
+IUSE="pymacs"
+
+DEPEND="pymacs? ( app-emacs/pymacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ if use pymacs; then
+ cp "${FILESDIR}"/setup.py "${S}"
+ else
+ rm -f "${S}"/pycomplete.{el,py}
+ fi
+}
+
+src_compile() {
+ elisp-comp *.el || die "elisp-comp failed"
+ use pymacs && distutils_src_compile
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc} || die
+ if use pymacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ distutils_src_install
+ else
+ # remove autoload for pycomplete from site file
+ sed '/pycomplete/d' "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" \
+ || die "sed failed"
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ use pymacs && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ elisp_pkg_postrm
+ use pymacs && distutils_pkg_postrm
+}