summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-26 17:31:07 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-26 17:31:07 +0000
commit14aa1cfca288bf35f68c845628671e078c0ae353 (patch)
tree15f1de7e3366253135f16bce38c382752fb94f21 /app-emacs/org-mode
parentStable on ppc wrt bug 218669 (diff)
downloadgentoo-2-14aa1cfca288bf35f68c845628671e078c0ae353.tar.gz
gentoo-2-14aa1cfca288bf35f68c845628671e078c0ae353.tar.bz2
gentoo-2-14aa1cfca288bf35f68c845628671e078c0ae353.zip
Major version bump.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-emacs/org-mode')
-rw-r--r--app-emacs/org-mode/ChangeLog7
-rw-r--r--app-emacs/org-mode/org-mode-6.02a.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
index e89edd8bcec0..531ae8dc9321 100644
--- a/app-emacs/org-mode/ChangeLog
+++ b/app-emacs/org-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/org-mode
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.28 2008/03/22 12:08:45 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.29 2008/04/26 17:31:07 ulm Exp $
+
+*org-mode-6.02a (26 Apr 2008)
+
+ 26 Apr 2008; Ulrich Mueller <ulm@gentoo.org> +org-mode-6.02a.ebuild:
+ Major version bump; upstream distribution has new directory structure.
22 Mar 2008; nixnut <nixnut@gentoo.org> org-mode-5.22a.ebuild:
Stable on ppc wrt bug 213910
diff --git a/app-emacs/org-mode/org-mode-6.02a.ebuild b/app-emacs/org-mode/org-mode-6.02a.ebuild
new file mode 100644
index 000000000000..5e3fbd0f0338
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-6.02a.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-6.02a.ebuild,v 1.1 2008/04/26 17:31:07 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://www.orgmode.org/"
+SRC_URI="http://orgmode.org/org-${PV}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+
+S="${WORKDIR}/org-${PV}"
+
+src_compile() {
+ # remove autoload file to make sure that it is regenerated with
+ # the right Emacs version
+ rm -f lisp/org-install.el
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ lispdir="${D}${SITELISP}/${PN}" \
+ infodir="${D}/usr/share/info" \
+ install || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+
+ mv doc/org doc/org.info
+ doinfo doc/org.info || die "doinfo failed"
+ dodoc README ChangeLog Changes.org doc/org.pdf doc/orgcard.pdf \
+ || die "dodoc failed"
+}