summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-04-12 18:07:37 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-04-12 18:07:37 +0000
commit9399b40b05c60baa6a0b39d0ac7974b4242e53b6 (patch)
tree1e8a1e4fc264d8ed072837673931a779113d3789 /app-emacs/mew/mew-6.3.ebuild
parentversion bump, reported by user on http://forums.gentoo.org/viewtopic-p-624134... (diff)
downloadgentoo-2-9399b40b05c60baa6a0b39d0ac7974b4242e53b6.tar.gz
gentoo-2-9399b40b05c60baa6a0b39d0ac7974b4242e53b6.tar.bz2
gentoo-2-9399b40b05c60baa6a0b39d0ac7974b4242e53b6.zip
version bump, reported by user on http://forums.gentoo.org/viewtopic-p-6241340.html
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-emacs/mew/mew-6.3.ebuild')
-rw-r--r--app-emacs/mew/mew-6.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/mew/mew-6.3.ebuild b/app-emacs/mew/mew-6.3.ebuild
new file mode 100644
index 000000000000..16555085540b
--- /dev/null
+++ b/app-emacs/mew/mew-6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mew/mew-6.3.ebuild,v 1.1 2010/04/12 18:07:37 fauli Exp $
+
+inherit elisp
+
+DESCRIPTION="Great MIME mail reader for Emacs/XEmacs"
+HOMEPAGE="http://www.mew.org/"
+SRC_URI="http://www.mew.org/Release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl linguas_ja"
+RESTRICT="test"
+
+RDEPEND="ssl? ( net-misc/stunnel )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ econf \
+ --with-elispdir=${SITELISP}/${PN} \
+ --with-etcdir=${SITEETC}/${PN}
+ emake || die
+
+ if use linguas_ja; then
+ emake jinfo || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use linguas_ja; then
+ emake DESTDIR="${D}" install-jinfo || die
+ fi
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc 00api 00changes* 00diff 00readme mew.dot.* || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please refer to /usr/share/doc/${PF} for sample configuration files."
+}