summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/igrep
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/igrep')
-rw-r--r--app-emacs/igrep/ChangeLog11
-rw-r--r--app-emacs/igrep/files/50igrep-gentoo.el36
-rw-r--r--app-emacs/igrep/files/digest-igrep-2.931
-rw-r--r--app-emacs/igrep/igrep-2.93.ebuild38
4 files changed, 86 insertions, 0 deletions
diff --git a/app-emacs/igrep/ChangeLog b/app-emacs/igrep/ChangeLog
new file mode 100644
index 000000000000..ce2f5191322f
--- /dev/null
+++ b/app-emacs/igrep/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/igrep
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/igrep/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*igrep-2.93 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ igrep-2.93.ebuild, files/50igrep-gentoo.el,
+ files/digest-igrep-2.93 :
+
+ Initial import.
diff --git a/app-emacs/igrep/files/50igrep-gentoo.el b/app-emacs/igrep/files/50igrep-gentoo.el
new file mode 100644
index 000000000000..6ff5f597ce76
--- /dev/null
+++ b/app-emacs/igrep/files/50igrep-gentoo.el
@@ -0,0 +1,36 @@
+
+;;; igrep site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
+(autoload 'igrep "igrep"
+ "*Run `grep` PROGRAM to match EXPRESSION in FILES..." t)
+(autoload 'igrep-find "igrep"
+ "*Run `grep` via `find`..." t)
+(autoload 'igrep-visited-files "igrep"
+ "*Run `grep` ... on all visited files." t)
+(autoload 'dired-do-igrep "igrep"
+ "*Run `grep` on the marked (or next prefix ARG) files." t)
+(autoload 'dired-do-igrep-find "igrep"
+ "*Run `grep` via `find` on the marked (or next prefix ARG) directories." t)
+(autoload 'Buffer-menu-igrep "igrep"
+ "*Run `grep` on the files visited in buffers marked with '>'." t)
+(autoload 'igrep-insinuate "igrep"
+ "Define `grep' aliases for the corresponding `igrep' commands." t)
+(autoload 'grep "igrep"
+ "*Run `grep` PROGRAM to match EXPRESSION in FILES..." t)
+(autoload 'egrep "igrep"
+ "*Run `egrep`..." t)
+(autoload 'fgrep "igrep"
+ "*Run `fgrep`..." t)
+(autoload 'agrep "igrep"
+ "*Run `agrep`..." t)
+(autoload 'grep-find "igrep"
+ "*Run `grep` via `find`..." t)
+(autoload 'egrep-find "igrep"
+ "*Run `egrep` via `find`..." t)
+(autoload 'fgrep-find "igrep"
+ "*Run `fgrep` via `find`..." t)
+(autoload 'agrep-find "igrep"
+ "*Run `agrep` via `find`..." t)
+
diff --git a/app-emacs/igrep/files/digest-igrep-2.93 b/app-emacs/igrep/files/digest-igrep-2.93
new file mode 100644
index 000000000000..3eab01715241
--- /dev/null
+++ b/app-emacs/igrep/files/digest-igrep-2.93
@@ -0,0 +1 @@
+MD5 5228517487f64cf41b52683deaf461ee igrep-2.93.tar.bz2 9643
diff --git a/app-emacs/igrep/igrep-2.93.ebuild b/app-emacs/igrep/igrep-2.93.ebuild
new file mode 100644
index 000000000000..49ec86a80de7
--- /dev/null
+++ b/app-emacs/igrep/igrep-2.93.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/igrep/igrep-2.93.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION='An improved interface to `grep` and `find`.'
+HOMEPAGE="ftp://ftp.cis.ohio-state.edu/pub/emacs-lisp/archive/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50igrep-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/igrep.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}