summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-17 19:21:45 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-17 19:21:45 +0000
commitc895afd3accdd3d3f984740327c73ce7d05793a0 (patch)
tree84004f9c2603c0ddeb63506048c997b0d7800781 /app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
parentUpdate gtk icon cache after merge/unmerge (diff)
downloadgentoo-2-c895afd3accdd3d3f984740327c73ce7d05793a0.tar.gz
gentoo-2-c895afd3accdd3d3f984740327c73ce7d05793a0.tar.bz2
gentoo-2-c895afd3accdd3d3f984740327c73ce7d05793a0.zip
Fixed compilation. Use autoload.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild')
-rw-r--r--app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild b/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
new file mode 100644
index 000000000000..dd071dbe2701
--- /dev/null
+++ b/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild,v 1.1 2007/04/17 19:21:45 ulm Exp $
+
+inherit elisp eutils
+
+MY_P=${PN}_${PV}+texinfo
+DESCRIPTION="Turn an Emacs buffer into display-equivalent HTML"
+HOMEPAGE="http://rtfm.etla.org/emacs/htmlfontify/"
+SRC_URI="http://rtfm.etla.org/emacs/htmlfontify/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SITEFILE=51${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-emacs22.patch
+}
+
+src_compile() {
+ elisp-compile *.el || die "elisp-compile failed"
+ makeinfo htmlfontify.texi || die "makeinfo failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo htmlfontify.info
+}