summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2004-01-05 05:11:38 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2004-01-05 05:11:38 +0000
commita4aecf53dd91a71077408920002e2092a00669e8 (patch)
treec42872772b850ce0a855aae68408f1dc8de7460d /app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild
parentmark stable on amd64 (diff)
downloadgentoo-2-a4aecf53dd91a71077408920002e2092a00669e8.tar.gz
gentoo-2-a4aecf53dd91a71077408920002e2092a00669e8.tar.bz2
gentoo-2-a4aecf53dd91a71077408920002e2092a00669e8.zip
Version bump, fixed copyright.
Diffstat (limited to 'app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild')
-rw-r--r--app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild b/app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild
new file mode 100644
index 000000000000..842444caffdc
--- /dev/null
+++ b/app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus-cvs/gnus-cvs-5.11.ebuild,v 1.1 2004/01/05 05:11:31 jbms Exp $
+
+ECVS_SERVER="cvs.gnus.org:/usr/local/cvsroot"
+ECVS_MODULE="gnus"
+ECVS_USER="gnus"
+ECVS_PASS="gnus"
+ECVS_CVS_OPTIONS="-dP"
+
+inherit elisp cvs
+
+IUSE="emacs-w3"
+
+S=${WORKDIR}/${ECVS_MODULE}
+DESCRIPTION="Current alpha branch of the Gnus news- and mail-reader"
+HOMEPAGE="http://www.gnus.org/"
+SRC_URI=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+# Never use the sandbox, it causes Emacs to segfault on startup
+SANDBOX_DISABLED="1"
+RESTRICT="$RESTRICT nostrip"
+
+DEPEND="virtual/emacs
+emacs-w3? app-emacs/w3"
+
+src_compile() {
+ local myconf
+ if [ $(use emacs-w3) ]; then
+ myconf="${myconf} --with-w3=/usr/share/emacs/site-lisp/w3"
+ myconf="${myconf} --with-url=/usr/share/emacs/site-lisp/w3"
+ else
+ myconf="${myconf} --without-w3 --without-url"
+ fi
+ econf \
+ --with-emacs \
+ --with-lispdir=/usr/share/emacs/site-lisp/gnus-cvs \
+ --with-etcdir=/usr/share/emacs/etc \
+ ${myconf}
+ emake || die
+}
+
+src_install() {
+ einstall \
+ lispdir=${D}/usr/share/emacs/site-lisp/gnus-cvs \
+ etcdir=${D}/usr/share/emacs/etc \
+ || die
+
+ elisp-site-file-install ${FILESDIR}/70${PN}-gentoo.el
+
+ dodoc ChangeLog GNUS-NEWS README todo
+
+ # fix info documentation
+ find ${D}/usr/share/info -type f -exec mv {} {}.info \;
+}