summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-03-14 21:54:07 +0000
committerUlrich Müller <ulm@gentoo.org>2008-03-14 21:54:07 +0000
commit99745c71c3be09158b0f76f5f40610122ac7fe39 (patch)
tree0829faf3c470b85abec2fc7157f0bdf08dbc45f2 /app-emacs/chess
parentproaudio is in herd not in maintainer (diff)
downloadgentoo-2-99745c71c3be09158b0f76f5f40610122ac7fe39.tar.gz
gentoo-2-99745c71c3be09158b0f76f5f40610122ac7fe39.tar.bz2
gentoo-2-99745c71c3be09158b0f76f5f40610122ac7fe39.zip
Allow alternative chess engines in RDEPEND.
Do not use custom-set-variables in site file. (Portage version: 2.1.4.4)
Diffstat (limited to 'app-emacs/chess')
-rw-r--r--app-emacs/chess/ChangeLog12
-rw-r--r--app-emacs/chess/chess-2.0_beta6-r1.ebuild51
-rw-r--r--app-emacs/chess/files/2.0_beta6-chess-common-handler-gentoo.patch18
-rw-r--r--app-emacs/chess/files/50chess-gentoo.el36
4 files changed, 115 insertions, 2 deletions
diff --git a/app-emacs/chess/ChangeLog b/app-emacs/chess/ChangeLog
index 5cfc7c1eb0a8..9ad4a8851af4 100644
--- a/app-emacs/chess/ChangeLog
+++ b/app-emacs/chess/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/chess
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.22 2007/10/26 17:58:45 ulm Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.23 2008/03/14 21:54:06 ulm Exp $
+
+*chess-2.0_beta6-r1 (14 Mar 2008)
+
+ 14 Mar 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/2.0_beta6-chess-common-handler-gentoo.patch,
+ +files/50chess-gentoo.el, +chess-2.0_beta6-r1.ebuild:
+ Allow alternative chess engines in RDEPEND. Do not use custom-set-variables
+ in site file since it is reserved for the user.
26 Oct 2007; Ulrich Mueller <ulm@gentoo.org>
-files/2.0_beta5-byte-compiling-files-gentoo.patch,
diff --git a/app-emacs/chess/chess-2.0_beta6-r1.ebuild b/app-emacs/chess/chess-2.0_beta6-r1.ebuild
new file mode 100644
index 000000000000..57e2376ea2f5
--- /dev/null
+++ b/app-emacs/chess/chess-2.0_beta6-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6-r1.ebuild,v 1.1 2008/03/14 21:54:06 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="http://emacs-chess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.gz
+ mirror://gentoo/emacs-chess-sounds-2.0.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-2.0.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( games-board/gnuchess
+ games-board/crafty
+ games-board/phalanx
+ games-board/sjeng )"
+
+S="${WORKDIR}/${PN}"
+
+SITEFILE=50${PN}-gentoo.el
+DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-chess-pos-move-gentoo.patch"
+ epatch "${FILESDIR}/${PV}-chess-common-handler-gentoo.patch"
+}
+
+# this is needed; elisp.eclass redefines src_compile() from portage default
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo chess.info
+ einfo "Installing sound files ..."
+ insinto /usr/share/sounds/${PN}
+ doins "${WORKDIR}"/sounds/*
+ einfo "Installing pixmap files ..."
+ insinto /usr/share/pixmaps/${PN}
+ doins -r "${WORKDIR}"/pieces/*
+}
diff --git a/app-emacs/chess/files/2.0_beta6-chess-common-handler-gentoo.patch b/app-emacs/chess/files/2.0_beta6-chess-common-handler-gentoo.patch
new file mode 100644
index 000000000000..0fd1e8c28264
--- /dev/null
+++ b/app-emacs/chess/files/2.0_beta6-chess-common-handler-gentoo.patch
@@ -0,0 +1,18 @@
+--- chess-orig/chess-common.el 2007-12-14 21:54:58.000000000 +0100
++++ chess/chess-common.el 2008-03-14 21:11:56.000000000 +0100
+@@ -41,10 +41,11 @@
+ (chess-message 'starting-engine name)
+ (unless (boundp path)
+ (chess-error 'could-not-find-engine name path))
+- (setq proc (start-process (concat "chess-" name)
+- (current-buffer) (symbol-value path)))
+- (chess-message 'starting-engine-done name)
+- proc))
++ (when (symbol-value path)
++ (setq proc (start-process (concat "chess-" name)
++ (current-buffer) (symbol-value path)))
++ (chess-message 'starting-engine-done name)
++ proc)))
+
+ ((eq event 'ready)
+ (chess-game-set-data game 'active t)
diff --git a/app-emacs/chess/files/50chess-gentoo.el b/app-emacs/chess/files/50chess-gentoo.el
new file mode 100644
index 000000000000..57c569558387
--- /dev/null
+++ b/app-emacs/chess/files/50chess-gentoo.el
@@ -0,0 +1,36 @@
+
+;;; chess site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'chess "chess"
+ "Start a game of chess, playing against ENGINE (a module name)." t)
+(defalias 'chess-session 'chess)
+(autoload 'chess-create-display "chess"
+ "Create a display, letting the user's customization decide the style.")
+(autoload 'chess-link "chess-link"
+ "Play out a game between two engines, and watch the progress." t)
+(autoload 'chess-pgn-read "chess-pgn"
+ "Read and display a PGN game after point." t)
+(autoload 'chess-pgn-mode "chess-pgn"
+ "A mode for editing chess PGN files." t)
+(defalias 'pgn-mode 'chess-pgn-mode)
+(autoload 'chess-puzzle "chess-puzzle"
+ "Pick a random puzzle from FILE, and solve it against the default engine." t)
+(autoload 'chess-fischer-random-position "chess-random"
+ "Generate a Fischer Random style position.")
+(autoload 'chess-tutorial "chess-tutorial"
+ "A simple chess training display." t)
+(autoload 'chess-ics "chess-ics"
+ "Connect to an Internet Chess Server." t)
+
+(add-to-list 'auto-mode-alist '("\\.pgn\\'" . chess-pgn-mode))
+
+(setq chess-images-directory "/usr/share/pixmaps/chess/xboard")
+(setq chess-sound-directory "/usr/share/sounds/chess")
+
+;; Change the order of the engine preference list to coincide with the order
+;; of our dependencies: games-board/gnuchess, crafty, phalanx, and sjeng.
+;; The user can override this using M-x customize-group RET chess RET
+(setq chess-default-engine
+ '(chess-gnuchess chess-crafty chess-phalanx chess-sjeng))