summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/apel
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/ChangeLog11
-rw-r--r--app-emacs/apel/apel-10.3.ebuild49
-rw-r--r--app-emacs/apel/apel-10.4.ebuild52
-rw-r--r--app-emacs/apel/files/50apel-gentoo.el4
-rw-r--r--app-emacs/apel/files/APEL-CFG.patch13
-rw-r--r--app-emacs/apel/files/digest-apel-10.31
-rw-r--r--app-emacs/apel/files/digest-apel-10.41
7 files changed, 131 insertions, 0 deletions
diff --git a/app-emacs/apel/ChangeLog b/app-emacs/apel/ChangeLog
new file mode 100644
index 000000000000..b431f2d51513
--- /dev/null
+++ b/app-emacs/apel/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/apel
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/ChangeLog,v 1.1 2002/11/01 02:52:00 mkennedy Exp $
+
+*apel-10.4 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ apel-10.4.ebuild, files/50apel-gentoo.el,
+ files/digest-apel-10.4, APEL-CFG.patch :
+
+ Initial import.
diff --git a/app-emacs/apel/apel-10.3.ebuild b/app-emacs/apel/apel-10.3.ebuild
new file mode 100644
index 000000000000..a1bcc7d62900
--- /dev/null
+++ b/app-emacs/apel/apel-10.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/apel-10.3.ebuild,v 1.1 2002/11/01 02:52:00 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs."
+HOMEPAGE="http://www.m17n.org/"
+SRC_URI="ftp://ftp.m17n.org/pub/mule/apel/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 <${FILESDIR}/APEL-CFG.patch || die
+}
+
+src_compile() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} install || die
+
+ elisp-site-file-install ${FILESDIR}/50apel-gentoo.el
+
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "See the /usr/share/doc/${P}/INSTALL.gz for tips on how to customize this package"
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/apel/apel-10.4.ebuild b/app-emacs/apel/apel-10.4.ebuild
new file mode 100644
index 000000000000..b30de789ba91
--- /dev/null
+++ b/app-emacs/apel/apel-10.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/apel-10.4.ebuild,v 1.1 2002/11/01 02:52:00 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs."
+HOMEPAGE="http://www.m17n.org/"
+SRC_URI="ftp://ftp.jpl.org/pub/elisp/apel/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/APEL-CFG.patch || die
+}
+
+src_compile() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} install || die
+
+ elisp-site-file-install ${FILESDIR}/50apel-gentoo.el
+
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ einfo "See the /usr/share/doc/${P}/README.en.gz for tips on how to customize this package"
+ einfo "And you need to rebuild packages depending on ${PN}."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/apel/files/50apel-gentoo.el b/app-emacs/apel/files/50apel-gentoo.el
new file mode 100644
index 000000000000..0cf9e85bff84
--- /dev/null
+++ b/app-emacs/apel/files/50apel-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; APEL site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
diff --git a/app-emacs/apel/files/APEL-CFG.patch b/app-emacs/apel/files/APEL-CFG.patch
new file mode 100644
index 000000000000..43bfb158b9eb
--- /dev/null
+++ b/app-emacs/apel/files/APEL-CFG.patch
@@ -0,0 +1,13 @@
+--- apel-10.3/APEL-CFG.org Sat Jun 23 19:25:54 2001
++++ apel-10.3/APEL-CFG Sat Jun 23 19:26:09 2001
+@@ -74,8 +74,8 @@
+ ;; XEmacs 21.0 and later.
+ ;; (setq PACKAGEDIR "/usr/local/lib/xemacs/xemacs-packages")
+
+-;; (setq APEL_PREFIX "apel")
+-;; (setq EMU_PREFIX "emu")
++(setq APEL_PREFIX "apel")
++(setq EMU_PREFIX "apel")
+
+ ;; If you want to install all of APEL modules to VERSION_SPECIFIC_LISPDIR,
+ ;; uncomment and edit this.
diff --git a/app-emacs/apel/files/digest-apel-10.3 b/app-emacs/apel/files/digest-apel-10.3
new file mode 100644
index 000000000000..777a2d662ce9
--- /dev/null
+++ b/app-emacs/apel/files/digest-apel-10.3
@@ -0,0 +1 @@
+MD5 a7357019aeeae69f95fb3cdc5a39bb1f apel-10.3.tar.gz 115847
diff --git a/app-emacs/apel/files/digest-apel-10.4 b/app-emacs/apel/files/digest-apel-10.4
new file mode 100644
index 000000000000..6f08e2c0c4a3
--- /dev/null
+++ b/app-emacs/apel/files/digest-apel-10.4
@@ -0,0 +1 @@
+MD5 51692379d36a226198cf5ed3b1b5e50e apel-10.4.tar.gz 127826