summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-07-29 21:03:37 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-07-29 21:03:37 +0000
commitf07b9df685a0d3698d54cc16d854d58516d2950d (patch)
treeea6242033965f2572e445fa7a7c20b1bc015017e /app-editors
parentbug 87104 (diff)
downloadgentoo-2-f07b9df685a0d3698d54cc16d854d58516d2950d.tar.gz
gentoo-2-f07b9df685a0d3698d54cc16d854d58516d2950d.tar.bz2
gentoo-2-f07b9df685a0d3698d54cc16d854d58516d2950d.zip
Added ~sh to KEYWORDS.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-21.4-r1.ebuild5
-rw-r--r--app-editors/emacs/files/emacs-21.2-sh.patch175
3 files changed, 183 insertions, 3 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 3f2d68e79c30..41f564fa30ae 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.69 2005/07/17 11:48:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.70 2005/07/29 21:03:37 matsuu Exp $
+
+ 29 Jul 2005; MATSUU Takuto <matsuu@gentoo.org> +files/emacs-21.2-sh.patch,
+ emacs-21.4-r1.ebuild:
+ Added emacs-21.2-sh.patch and ~sh to KEYWORDS.
17 Jul 2005; Tobias Scherbaum <dertobi123@gentoo.org>
emacs-21.4-r1.ebuild:
diff --git a/app-editors/emacs/emacs-21.4-r1.ebuild b/app-editors/emacs/emacs-21.4-r1.ebuild
index bacb7dad0f81..d0ff088883ad 100644
--- a/app-editors/emacs/emacs-21.4-r1.ebuild
+++ b/app-editors/emacs/emacs-21.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r1.ebuild,v 1.12 2005/07/17 11:48:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r1.ebuild,v 1.13 2005/07/29 21:03:37 matsuu Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
LICENSE="GPL-2"
SLOT="21"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 s390 sparc x86"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 s390 ~sh sparc x86"
IUSE="X Xaw3d gnome leim lesstif motif nls nosendmail"
RDEPEND="sys-libs/ncurses
@@ -47,6 +47,7 @@ src_unpack() {
epatch ${FILESDIR}/emacs-21.3-xorg.patch
epatch ${FILESDIR}/emacs-21.3-amd64.patch
epatch ${FILESDIR}/emacs-21.3-hppa.patch
+ epatch ${FILESDIR}/emacs-21.2-sh.patch
use ppc64 && epatch ${FILESDIR}/emacs-21.3-ppc64.patch
epatch ${FILESDIR}/emacs-subdirs-el-gentoo.diff
diff --git a/app-editors/emacs/files/emacs-21.2-sh.patch b/app-editors/emacs/files/emacs-21.2-sh.patch
new file mode 100644
index 000000000000..254db249fc0f
--- /dev/null
+++ b/app-editors/emacs/files/emacs-21.2-sh.patch
@@ -0,0 +1,175 @@
+--- emacs21-21.2.orig/configure.in
++++ emacs21-21.2/configure.in
+@@ -1055,6 +1055,16 @@
+ machine=mipsel opsys=gnu-linux
+ ;;
+
++ ## SuperH (little endian) Linux-based GNU system
++ sh[34]-*-linux-gnu* )
++ machine=sh opsys=gnu-linux
++ ;;
++
++ ## SuperH (big endian) Linux-based GNU system
++ sh[34]eb-*-linux-gnu* )
++ machine=sheb opsys=gnu-linux
++ ;;
++
+ ## UXP/DS
+ sparc-fujitsu-sysv4* )
+ machine=sparc opsys=uxpds
+--- emacs21-21.2.orig/src/m/sh.h
++++ emacs21-21.2/src/m/sh.h
+@@ -0,0 +1,122 @@
++/* machine description file for Hitach SuperH.
++ Copyright (C) 2000 Free Software Foundation, Inc.
++
++This file is part of GNU Emacs.
++
++GNU Emacs is free software; you can redistribute it and/or modify
++it under the terms of the GNU General Public License as published by
++the Free Software Foundation; either version 2, or (at your option)
++any later version.
++
++GNU Emacs is distributed in the hope that it will be useful,
++but WITHOUT ANY WARRANTY; without even the implied warranty of
++MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++GNU General Public License for more details.
++
++You should have received a copy of the GNU General Public License
++along with GNU Emacs; see the file COPYING. If not, write to
++the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
++Boston, MA 02111-1307, USA. */
++
++
++/* The following line tells the configuration script what sort of
++ operating system this machine is likely to run.
++ USUAL-OPSYS="<name of system .h file here, without the s- or .h>" */
++
++/* Define WORDS_BIG_ENDIAN iff lowest-numbered byte in a word
++ is the most significant byte. */
++
++#undef WORDS_BIG_ENDIAN
++
++/* Define NO_ARG_ARRAY if you cannot take the address of the first of a
++ * group of arguments and treat it as an array of the arguments. */
++
++#define NO_ARG_ARRAY
++
++/* Define WORD_MACHINE if addresses and such have
++ * to be corrected before they can be used as byte counts. */
++
++#undef WORD_MACHINE
++
++/* Now define a symbol for the cpu type, if your compiler
++ does not define it automatically:
++ Ones defined so far include vax, m68000, ns16000, pyramid,
++ orion, tahoe, APOLLO and many others */
++#define SUPERH
++
++/* Use type int rather than a union, to represent Lisp_Object */
++/* This is desirable for most machines. */
++
++#define NO_UNION_TYPE
++
++/* Define EXPLICIT_SIGN_EXTEND if XINT must explicitly sign-extend
++ the 24-bit bit field into an int. In other words, if bit fields
++ are always unsigned.
++
++ If you use NO_UNION_TYPE, this flag does not matter. */
++
++#define EXPLICIT_SIGN_EXTEND
++
++/* Data type of load average, as read out of kmem. */
++
++#define LOAD_AVE_TYPE long
++
++/* Convert that into an integer that is 100 for a load average of 1.0 */
++
++#define LOAD_AVE_CVT(x) (int) (((double) (x)) * 100.0 / FSCALE)
++
++/* Define CANNOT_DUMP on machines where unexec does not work.
++ Then the function dump-emacs will not be defined
++ and temacs will do (load "loadup") automatically unless told otherwise. */
++
++#undef CANNOT_DUMP
++
++/* Define VIRT_ADDR_VARIES if the virtual addresses of
++ pure and impure space as loaded can vary, and even their
++ relative order cannot be relied on.
++
++ Otherwise Emacs assumes that text space precedes data space,
++ numerically. */
++
++#undef VIRT_ADDR_VARIES
++
++/* Define C_ALLOCA if this machine does not support a true alloca
++ and the one written in C should be used instead.
++ Define HAVE_ALLOCA to say that the system provides a properly
++ working alloca function and it should be used.
++ Define neither one if an assembler-language alloca
++ in the file alloca.s should be used. */
++
++#undef C_ALLOCA
++#define HAVE_ALLOCA
++
++/* Define NO_REMAP if memory segmentation makes it not work well
++ to change the boundary between the text section and data section
++ when Emacs is dumped. If you define this, the preloaded Lisp
++ code will not be sharable; but that's better than failing completely. */
++
++#undef NO_REMAP
++
++/* Some really obscure 4.2-based systems (like Sequent DYNIX)
++ * do not support asynchronous I/O (using SIGIO) on sockets,
++ * even though it works fine on tty's. If you have one of
++ * these systems, define the following, and then use it in
++ * config.h (or elsewhere) to decide when (not) to use SIGIO.
++ *
++ * You'd think this would go in an operating-system description file,
++ * but since it only occurs on some, but not all, BSD systems, the
++ * reasonable place to select for it is in the machine description
++ * file.
++ */
++
++#undef NO_SOCK_SIGIO
++
++
++/* After adding support for a new system, modify the large case
++ statement in the `configure' script to recognize reasonable
++ configuration names, and add a description of the system to
++ `etc/MACHINES'.
++
++ If you've just fixed a problem in an existing configuration file,
++ you should also check `etc/MACHINES' to make sure its descriptions
++ of known problems in that configuration should be updated. */
+only in patch2:
+--- emacs21-21.2.orig/src/m/sheb.h
++++ emacs21-21.2/src/m/sheb.h
+@@ -0,0 +1,8 @@
++/* machine description file for sheb (SuperH big endian). */
++
++#include "sh.h"
++
++/* Define WORDS_BIG_ENDIAN iff lowest-numbered byte in a word
++ is the most significant byte. */
++
++#define WORDS_BIG_ENDIAN
+--- emacs-21.2.orig/configure Fri Mar 15 21:46:09 2002
++++ emacs-21.2/configure Mon Nov 25 16:30:19 2002
+@@ -1666,6 +1666,16 @@
+ machine=mips opsys=gnu-linux
+ ;;
+
++ ## SuperH (little endian) Linux-based GNU system
++ sh[34]-*-linux-gnu* )
++ machine=sh opsys=gnu-linux
++ ;;
++
++ ## SuperH (big endian) Linux-based GNU system
++ sh[34]eb-*-linux-gnu* )
++ machine=sheb opsys=gnu-linux
++ ;;
++
+ ## UXP/DS
+ sparc-fujitsu-sysv4* )
+ machine=sparc opsys=uxpds