summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-12 20:25:50 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-12 20:25:50 +0000
commit91f483ef4d9f6a4d89ba5f1f710faba17d3bfc27 (patch)
tree9326545e19a2ff80e51670c45220edda7f9b508f /app-editors
parentCVS snap version bump from Samuli Suominen via bug #280236 (diff)
downloadgentoo-2-91f483ef4d9f6a4d89ba5f1f710faba17d3bfc27.tar.gz
gentoo-2-91f483ef4d9f6a4d89ba5f1f710faba17d3bfc27.tar.bz2
gentoo-2-91f483ef4d9f6a4d89ba5f1f710faba17d3bfc27.zip
Version bump to 3.5a
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/levee/ChangeLog8
-rw-r--r--app-editors/levee/files/levee-3.5a-QA.patch16
-rw-r--r--app-editors/levee/levee-3.5a.ebuild35
3 files changed, 58 insertions, 1 deletions
diff --git a/app-editors/levee/ChangeLog b/app-editors/levee/ChangeLog
index 5583089be2cb..f8c9d13662a3 100644
--- a/app-editors/levee/ChangeLog
+++ b/app-editors/levee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/levee
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.18 2009/08/12 19:36:35 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.19 2009/08/12 20:25:50 vostorga Exp $
+
+*levee-3.5a (12 Aug 2009)
+
+ 12 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> +levee-3.5a.ebuild,
+ +files/levee-3.5a-QA.patch:
+ Version bump to 3.5a
12 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> -levee-3.4o.ebuild:
Cleaning out old version
diff --git a/app-editors/levee/files/levee-3.5a-QA.patch b/app-editors/levee/files/levee-3.5a-QA.patch
new file mode 100644
index 000000000000..7e37c76b34ac
--- /dev/null
+++ b/app-editors/levee/files/levee-3.5a-QA.patch
@@ -0,0 +1,16 @@
+diff -NrU5 levee-3.5a.original/configure.inc levee-3.5a/configure.inc
+--- levee-3.5a.original/configure.inc 2009-08-12 19:51:26.000000000 +0000
++++ levee-3.5a/configure.inc 2009-08-12 20:13:41.000000000 +0000
+@@ -1074,11 +1074,11 @@
+ else
+ PROG_INSTALL="$DEST"
+ fi
+
+ AC_SUB 'INSTALL' "$PROG_INSTALL"
+- AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -s -m 755"
++ AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -m 755"
+ AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 444"
+
+ # finally build a little directory installer
+ # if mkdir -p works, use that, otherwise use install -d,
+ # otherwise build a script to do it by hand.
diff --git a/app-editors/levee/levee-3.5a.ebuild b/app-editors/levee/levee-3.5a.ebuild
new file mode 100644
index 000000000000..1ecc1e033145
--- /dev/null
+++ b/app-editors/levee/levee-3.5a.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5a.ebuild,v 1.1 2009/08/12 20:25:50 vostorga Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Really tiny vi clone, for things like rescue disks"
+HOMEPAGE="http://www.pell.chi.il.us/~orc/Code/"
+SRC_URI="http://www.pell.chi.il.us/~orc/Code/levee/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="levee"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE=""
+DEPEND="!app-text/lv
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-QA.patch
+ epatch "${FILESDIR}"/${PN}-3.5-glibc210.patch
+}
+
+src_compile() {
+ ./configure.sh --prefix=/usr || die "configure failed"
+ emake CFLAGS="${CFLAGS} -Wall -Wextra ${LDFLAGS}" \
+ CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}" install || die "emake install failed"
+}