summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-01-21 17:50:39 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-01-21 17:50:39 +0000
commit5eed2a5e9e7af333e2ef2b92447d979a8c55a588 (patch)
treef940c9c3b425d9d3e744cbd23b3f96806170e594 /app-editors
parentnew version (diff)
downloadgentoo-2-5eed2a5e9e7af333e2ef2b92447d979a8c55a588.tar.gz
gentoo-2-5eed2a5e9e7af333e2ef2b92447d979a8c55a588.tar.bz2
gentoo-2-5eed2a5e9e7af333e2ef2b92447d979a8c55a588.zip
Patches 1-300
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/files/digest-gvim-6.1-r62
-rw-r--r--app-editors/gvim/gvim-6.1-r6.ebuild97
-rw-r--r--app-editors/vim-core/ChangeLog7
-rw-r--r--app-editors/vim-core/files/digest-vim-core-6.1-r42
-rw-r--r--app-editors/vim-core/vim-core-6.1-r4.ebuild57
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/files/digest-vim-6.1-r192
-rw-r--r--app-editors/vim/vim-6.1-r19.ebuild87
9 files changed, 265 insertions, 3 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index 2f2eca82e168..bf99cd30227b 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-editors/gvim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.13 2003/01/14 18:50:13 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.14 2003/01/21 17:50:39 rphillips Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*gvim-6.1-r6.ebuild (21 Jan 2003)
+
+ 21 Jan 2003; Ryan Phillips <rphillips@gentoo.org> gvim-6.1-r6.ebuild :
+ Patches 1-300
+
*gvim-6.1-r5.ebuild (14 Jan 2003)
14 Jan 2003; Ryan Phillips <rphillips@gentoo.org> gvim-6.1-r5.ebuild :
diff --git a/app-editors/gvim/files/digest-gvim-6.1-r6 b/app-editors/gvim/files/digest-gvim-6.1-r6
new file mode 100644
index 000000000000..374f8fa02618
--- /dev/null
+++ b/app-editors/gvim/files/digest-gvim-6.1-r6
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 9ead3eaf912e0b63aae3ee5b55b70f25 vimpatch-1-300.tar.bz2 220361
diff --git a/app-editors/gvim/gvim-6.1-r6.ebuild b/app-editors/gvim/gvim-6.1-r6.ebuild
new file mode 100644
index 000000000000..b5ee6a4263b0
--- /dev/null
+++ b/app-editors/gvim/gvim-6.1-r6.ebuild
@@ -0,0 +1,97 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r6.ebuild,v 1.1 2003/01/21 17:50:39 rphillips Exp $
+
+VIMPATCH="vimpatch-1-300.tar.bz2"
+inherit vim
+
+DESCRIPTION="graphical vim"
+KEYWORDS="~x86 ~alpha"
+DEPEND="dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ sys-libs/libtermcap-compat
+ app-editors/vim-core
+ x11-base/xfree
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gnome? ( gnome-base/gnome-libs )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+# It appears that the tclinterp stuff in Vim is broken right now (at
+# least on Linux... it works on BSD). When you --enable-tclinterp
+# flag, then the following command never returns:
+#
+# VIMINIT='let OS = system("uname -s")' vim
+#
+# Please don't re-enable the tclinterp flag without verifying first
+# that the above works. Thanks. (08 Sep 2001 agriffis)
+
+src_compile() {
+ #default myconf options added by ZhEN on 11/20/02 for unicode support
+ local myconf="--with-features=big --enable-multibyte"
+ use nls && myconf="--enable-multibyte" || myconf="--disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ if use gnome; then
+ guiconf="--enable-gui=gnome --with-x"
+ elif use gtk; then
+ guiconf="--enable-gui=gtk --with-x"
+ else
+ guiconf="--enable-gui=athena --with-x"
+ fi
+
+ # This should fix a sandbox violation.
+ addwrite /dev/pty/*
+ addpredict /dev/pty/
+
+ if [ -n "$guiconf" ]; then
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --enable-cscope $myconf $guiconf \
+ --with-vim-name=gvim || die "gvim configure failed"
+
+ # move config files to /etc/vim/
+ echo "#define SYS_VIMRC_FILE \"/etc/vim/vimrc\"" \
+ >>${WORKDIR}/vim61/src/feature.h
+ echo "#define SYS_GVIMRC_FILE \"/etc/vim/gvimrc\"" \
+ >>${WORKDIR}/vim61/src/feature.h
+
+ # Parallel make does not work
+ make || die "gvim make failed"
+ fi
+}
+
+src_install() {
+ dobin src/gvim
+ ln -s gvim ${D}/usr/bin/gvimdiff
+ # Default gvimrc
+ insinto /etc/vim/
+ doins ${FILESDIR}/gvimrc
+}
+
+#added by ZhEN 11/20/02 for unicode
+pkg_postinst() {
+ einfo
+ einfo "To enable UTF-8 viewing, set guifont and guifontwide: "
+ einfo ":set guifont=-misc-fixed-medium-r-normal-*-18-120-100-100-c-90-iso10646-1"
+ einfo ":set guifontwide=-misc-fixed-medium-r-normal-*-18-120-100-100-c-180-iso10646-1"
+ einfo
+ einfo "note: to find out which fonts you can use, please read the UTF-8 help:"
+ einfo ":h utf-8"
+ einfo
+ einfo "Then, set read encoding to UTF-8:"
+ einfo ":set encoding=utf-8"
+ einfo
+
+}
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 6d34d5e4444c..5ce68213cc78 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.9 2002/12/13 10:56:06 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.10 2003/01/21 17:50:39 rphillips Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
@@ -8,6 +8,11 @@
set all builds except 6.1-r3 to -ppc, the -r3 build is now
ppc (its only one that works on ppc)
+*vim-core-6.1-r4 (21 Jan 2003)
+
+ 21 Jan 2003; Ryan Phillips <rphillips@gentoo.org> vim-core-6.1-r4.ebuild :
+ Patches 1-300
+
*vim-core-6.1-r3 (27 Oct 2002)
12 Nov 2002; Ryan Phillips <rphillips@gentoo.org> vim-core-6.1-r3.ebuild :
diff --git a/app-editors/vim-core/files/digest-vim-core-6.1-r4 b/app-editors/vim-core/files/digest-vim-core-6.1-r4
new file mode 100644
index 000000000000..374f8fa02618
--- /dev/null
+++ b/app-editors/vim-core/files/digest-vim-core-6.1-r4
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 9ead3eaf912e0b63aae3ee5b55b70f25 vimpatch-1-300.tar.bz2 220361
diff --git a/app-editors/vim-core/vim-core-6.1-r4.ebuild b/app-editors/vim-core/vim-core-6.1-r4.ebuild
new file mode 100644
index 000000000000..d5c5b42d124f
--- /dev/null
+++ b/app-editors/vim-core/vim-core-6.1-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r4.ebuild,v 1.1 2003/01/21 17:50:39 rphillips Exp $
+
+VIMPATCH="vimpatch-1-300.tar.bz2"
+inherit vim
+
+DESCRIPTION="vim, gvim and kvim shared files"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND="dev-util/cscope
+ sys-libs/libtermcap-compat
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+
+src_compile() {
+
+ local myconf
+ use nls && myconf="--enable-multibyte" || myconf="--disable-nls"
+ myconf="$myconf --disable-perlinterp --disable-pythoninterp --disable-rubyinterp"
+ myconf="$myconf --disable-gpm"
+
+ # This should fix a sandbox violation.
+ addwrite "${SSH_TTY}"
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=tiny $myconf \
+ --enable-gui=no --without-x \
+ || die "vim configure failed"
+ # Parallel make does not work
+ make tools || die "vim make failed"
+ cd ${S}
+ rm src/vim
+}
+
+src_install() {
+ mkdir -p $D/usr/{bin,share/man/man1,share/vim}
+ cd src
+ make installruntime installhelplinks installmacros installtutor installtools install-languages install-icons DESTDIR=$D \
+ BINDIR=/usr/bin MANDIR=/usr/share/man DATADIR=/usr/share || die "make install failed"
+ # Docs
+ dodoc README*
+ cd $D/usr/share/doc/$PF
+ ln -s ../../vim/*/doc $P
+
+ #fix problems with vim not finding its data files.
+ dodir /etc/env.d
+ echo "VIMRUNTIME=/usr/share/vim/vim${vim_version/.}" \
+ >${D}/etc/env.d/40vim
+}
+
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index bb9dfe480548..8a92b43f415b 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.38 2003/01/20 14:21:13 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.39 2003/01/21 17:50:39 rphillips Exp $
+
+*vim-6.1-r19.ebuild (21 Jan 2003)
+
+ 21 Jan 2003; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r19.ebuild :
+ patches 1-300
*vim-6.1-r18.ebuild (14 Jan 2003)
diff --git a/app-editors/vim/files/digest-vim-6.1-r19 b/app-editors/vim/files/digest-vim-6.1-r19
new file mode 100644
index 000000000000..374f8fa02618
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.1-r19
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 9ead3eaf912e0b63aae3ee5b55b70f25 vimpatch-1-300.tar.bz2 220361
diff --git a/app-editors/vim/vim-6.1-r19.ebuild b/app-editors/vim/vim-6.1-r19.ebuild
new file mode 100644
index 000000000000..35366381061e
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r19.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r19.ebuild,v 1.1 2003/01/21 17:50:39 rphillips Exp $
+
+IUSE="nls perl python ruby tcltk gpm X"
+
+VIMPATCH="vimpatch-1-300.tar.bz2"
+inherit vim
+
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~x86 ~sparc ~alpha"
+DEPEND="app-editors/vim-core
+ sys-libs/libtermcap-compat
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+
+PROVIDE="virtual/editor"
+
+src_compile() {
+ local myconf
+ myconf="--with-features=big --enable-multibyte"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # the console vim will change the caption of a terminal in X.
+ # the configure script should autodetect X being installed, so
+ # we'll specifically turn it off if X is not in the USE vars.
+ # -rphillips
+ use X && myconf="$myconf --with-x"
+
+ # This should fix a sandbox violation.
+ for file in /dev/pty/s*
+ do
+ addwrite $file
+ done
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --enable-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+
+ # move config files to /etc/vim/
+ echo "#define SYS_VIMRC_FILE \"/etc/vim/vimrc\"" \
+ >>${WORKDIR}/vim61/src/feature.h
+ echo "#define SYS_GVIMRC_FILE \"/etc/vim/gvimrc\"" \
+ >>${WORKDIR}/vim61/src/feature.h
+
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ ln -s vim ${D}/usr/bin/rvim
+ ln -s vim ${D}/usr/bin/ex
+ ln -s vim ${D}/usr/bin/view
+ ln -s vim ${D}/usr/bin/rview
+
+ # Default vimrc
+ insinto /etc/vim/
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}