summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-11 01:39:12 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-11 01:39:12 +0000
commit2a9f226767ef23d0d8b7871288ce61d1450dfd7a (patch)
tree46a212fce66075e7874cc7352e06413fd157e408 /app-editors
parentChecked FHS compatibility added ps and de docs (diff)
downloadgentoo-2-2a9f226767ef23d0d8b7871288ce61d1450dfd7a.tar.gz
gentoo-2-2a9f226767ef23d0d8b7871288ce61d1450dfd7a.tar.bz2
gentoo-2-2a9f226767ef23d0d8b7871288ce61d1450dfd7a.zip
FHS2.1 fixes, added .info suffix to emacs info files, dependencie cleanup
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-motif/emacs-motif-20.7-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/emacs-motif/emacs-motif-20.7-r2.ebuild b/app-editors/emacs-motif/emacs-motif-20.7-r2.ebuild
new file mode 100644
index 000000000000..e3ea75b5671c
--- /dev/null
+++ b/app-editors/emacs-motif/emacs-motif-20.7-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+
+A=emacs-20.7.tar.gz
+S=${WORKDIR}/emacs-20.7
+DESCRIPTION="An incredibly powerful, extensible text editor (X11/Motif version)"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/emacs/emacs-20.7.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ >=x11-libs/openmotif-2.1.30
+ !app-editors/emacs-nogui
+ !app-editors/emacs-x11"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=x11-libs/openmotif-2.1.30
+ >=sys-devel/gettext-0.10.35"
+
+src_compile() {
+ try ./configure --prefix=/usr --libexecdir=/usr/lib --host=${CHOST} \
+ --mandir=/usr/share/man --infodir=/usr/share/info --with-x-toolkit=motif --with-x
+ try make
+}
+
+src_install () {
+ try make prefix=${D}/usr libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ cd ${D}/usr/share/info
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+ dodoc BUGS ChangeLog README
+}
+