summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-10 18:57:08 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-10 18:57:08 +0000
commit1dfcbc8e0d8288e25a6aac6119c02b726b2cd1aa (patch)
treeffbd122a2061976dce1d1ac9bd27550588f2b597 /app-editors
parentVersion bump. Bug #385749 (diff)
downloadgentoo-2-1dfcbc8e0d8288e25a6aac6119c02b726b2cd1aa.tar.gz
gentoo-2-1dfcbc8e0d8288e25a6aac6119c02b726b2cd1aa.tar.bz2
gentoo-2-1dfcbc8e0d8288e25a6aac6119c02b726b2cd1aa.zip
Drop .la files as I have just test plugins work still, bug #386665 by Ago. Drop old
(Portage version: 2.1.10.25/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit-plugins/ChangeLog7
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild111
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild3
-rw-r--r--app-editors/gedit-plugins/metadata.xml10
4 files changed, 8 insertions, 123 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 760714fb5e17..0d848550a54f 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.17 2011/09/27 17:25:55 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.18 2011/10/10 18:57:08 pacho Exp $
+
+ 10 Oct 2011; Pacho Ramos <pacho@gentoo.org> -gedit-plugins-2.30.0.ebuild,
+ gedit-plugins-2.32.0.ebuild:
+ Drop .la files as I have just test plugins work still, bug #386665 by Ago.
+ Drop old
27 Sep 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
gedit-plugins-3.0.7.ebuild:
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild
deleted file mode 100644
index 15ef203bc72f..000000000000
--- a/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild,v 1.6 2011/05/02 19:12:17 arfrever Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="session? 2:2.6"
-PYTHON_USE_WITH="xml"
-PYTHON_USE_WITH_OPT="session"
-
-inherit gnome2 multilib python eutils
-
-DESCRIPTION="Offical plugins for gedit."
-HOMEPAGE="http://live.gnome.org/GeditPlugins"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-IUSE="bookmarks +bracketcompletion charmap colorpicker +drawspaces +joinlines python +session showtabbar smartspaces terminal"
-
-RDEPEND=">=x11-libs/gtk+-2.14:2
- gnome-base/gconf
- >=x11-libs/gtksourceview-2.6:2.0
- >=app-editors/gedit-2.29.3[python]
- >=dev-python/pygtk-2.14:2
- charmap? (
- >=gnome-extra/gucharmap-2.24.3
- )
- python? (
- >=dev-python/pygtksourceview-2.2:2
- )
- terminal? (
- dev-python/gconf-python
- >=x11-libs/vte-0.19.4:0[python]
- )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool"
-
-DOCS="AUTHORS NEWS ChangeLog*"
-
-pkg_setup() {
- local myplugins="codecomment"
-
- for plugin in ${IUSE/python}; do
- if use session && [ "${plugin/+}" = "session" ]; then
- myplugins="${myplugins},sessionsaver"
- elif use ${plugin/+}; then
- myplugins="${myplugins},${plugin/+}"
- fi
- done
-
- G2CONF="${G2CONF}
- --disable-dependency-tracking
- --with-plugins=${myplugins}
- $(use_enable python)"
-
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Fix issues with find/replace in selections
- epatch "${FILESDIR}/${P}-find-replace.patch"
-
- # Add Ctrl+Shift+C/V copy paste accelerators to terminal
- epatch "${FILESDIR}/${P}-copy-paste.patch"
-
- # Improved handling of scrolling for replace-all command
- epatch "${FILESDIR}/${P}-replace-all.patch"
-
- # Fix background color of the commander entry
- epatch "${FILESDIR}/${P}-background-color.patch"
-
- # Make multi edit keybinding toggle multi edit mode
- epatch "${FILESDIR}/${P}-keybinding-toggle.patch"
-
- # Make multi edit menu item proper toggle item
- epatch "${FILESDIR}/${P}-edit-menu.patch"
-
- # Added commander toggle menu item
- epatch "${FILESDIR}/${P}-commander-menu.patch"
-
- # disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
-}
-
-src_test() {
- emake check || die "make check failed"
-}
-
-src_install() {
- gnome2_src_install
- # gedit doesn't rely on *.la files
- find "${D}" -name "*.la" -delete || die "*.la files removal failed"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_need_rebuild
- python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
-}
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild
index 69f4710cefe6..5e8b167f33a3 100644
--- a/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild,v 1.1 2011/06/24 13:31:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.32.0.ebuild,v 1.2 2011/10/10 18:57:08 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="python? 2:2.6"
PYTHON_USE_WITH="xml"
PYTHON_USE_WITH_OPT="python"
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
index 6614b58e71e5..2bf095e72b0f 100644
--- a/app-editors/gedit-plugins/metadata.xml
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -4,18 +4,8 @@
<herd>gnome</herd>
<longdescription>Official plugins for gedit</longdescription>
<use>
- <flag name='bookmarks'>Advanced Bookmarking, it remembers all the
- bookmarks you ever toggled, highlights them in the text and allows
- you to navigate through a list with the navigation pane</flag>
- <flag name='bracketcompletion'>Automatically adds closing brackets</flag>
<flag name='charmap'>Insert special characters just by clicking on
them</flag>
- <flag name='colorpicker'>Pick a color from a dialog and insert its
- hexadecimal representation</flag>
- <flag name='drawspaces'>Draw spaces and tabs</flag>
- <flag name='joinlines'>Join several lines or split long ones</flag>
- <flag name='showtabbar'>Add a menu entry to show/hide the tabbar</flag>
- <flag name='smartspaces'>Forget you're not using tabulations</flag>
<flag name='synctex'>Synchronize between LaTeX and PDF with gedit and
evince</flag>
<flag name='terminal'>Embed a terminal in the bottom pane</flag>