summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-06-23 09:56:19 +0000
committerAli Polatel <hawking@gentoo.org>2007-06-23 09:56:19 +0000
commit14df81bc7283eae5d272bce0c19f8834e3d1c8e9 (patch)
tree80aa8408b8b101a50150f200e7fe7270bad22061 /app-editors
parentVersion bump (diff)
downloadgentoo-2-14df81bc7283eae5d272bce0c19f8834e3d1c8e9.tar.gz
gentoo-2-14df81bc7283eae5d272bce0c19f8834e3d1c8e9.tar.bz2
gentoo-2-14df81bc7283eae5d272bce0c19f8834e3d1c8e9.zip
check tk support for python, fix headers, cosmetics
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/leo/ChangeLog7
-rw-r--r--app-editors/leo/leo-4.2.ebuild18
-rw-r--r--app-editors/leo/leo-4.4.1_beta2.ebuild19
3 files changed, 28 insertions, 16 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index 982c7f4d5173..0289d6ab4c76 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/leo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.8 2007/02/21 21:20:38 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.9 2007/06/23 09:56:19 hawking Exp $
+
+ 23 Jun 2007; Ali Polatel <hawking@gentoo.org> leo-4.2.ebuild,
+ leo-4.4.1_beta2.ebuild:
+ check tk support for python (bug #154459, thanks to Cliff Yapp), fix
+ headers, cosmetics
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-editors/leo/leo-4.2.ebuild b/app-editors/leo/leo-4.2.ebuild
index 450d8e4239a6..129a3f7f453f 100644
--- a/app-editors/leo/leo-4.2.ebuild
+++ b/app-editors/leo/leo-4.2.ebuild
@@ -1,26 +1,30 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.6 2005/09/16 03:06:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.7 2007/06/23 09:56:19 hawking Exp $
+
+NEED_PYTHON=2.3
inherit eutils python
MY_P=${P}-final
DESCRIPTION="Leo is an outlining editor and literate programming tool."
HOMEPAGE="http://leo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
LICENSE="PYTHON"
SLOT="0"
KEYWORDS="ppc x86"
IUSE=""
-RDEPEND="virtual/python
- dev-lang/tk"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="app-arch/unzip"
+RDEPEND=""
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ python_tkinter_exists
+}
+
src_unpack() {
unpack ${A}
cd "${S}" || die "Failed to cd ${S}"
diff --git a/app-editors/leo/leo-4.4.1_beta2.ebuild b/app-editors/leo/leo-4.4.1_beta2.ebuild
index 8751153bc2e0..44f55e64d031 100644
--- a/app-editors/leo/leo-4.4.1_beta2.ebuild
+++ b/app-editors/leo/leo-4.4.1_beta2.ebuild
@@ -1,27 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.4.1_beta2.ebuild,v 1.1 2006/06/25 21:46:40 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.4.1_beta2.ebuild,v 1.2 2007/06/23 09:56:19 hawking Exp $
+
+NEED_PYTHON=2.3
inherit eutils python
MY_P="${PN}-4-4-1-beta-2"
DESCRIPTION="Leo is an outlining editor and literate programming tool."
HOMEPAGE="http://leo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
LICENSE="PYTHON"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND="virtual/python
- dev-lang/tk"
-
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="app-arch/unzip"
+RDEPEND=""
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ python_tkinter_exists
+}
+
src_unpack() {
unpack ${A}
cd "${S}"