summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-11 13:05:52 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-11 13:05:52 +0000
commit926e6790a8c84e448dd20166b8546527d1c20092 (patch)
tree7ec9e4db9fe62899da9865d9162f1729b6f3f580 /app-editors/zile/zile-2.0.0.ebuild
parentAdded a new snapshot to portage (diff)
downloadgentoo-2-926e6790a8c84e448dd20166b8546527d1c20092.tar.gz
gentoo-2-926e6790a8c84e448dd20166b8546527d1c20092.tar.bz2
gentoo-2-926e6790a8c84e448dd20166b8546527d1c20092.zip
Version bumped. This closes bug #81214.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-editors/zile/zile-2.0.0.ebuild')
-rw-r--r--app-editors/zile/zile-2.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.0.0.ebuild b/app-editors/zile/zile-2.0.0.ebuild
new file mode 100644
index 000000000000..0c742b766c50
--- /dev/null
+++ b/app-editors/zile/zile-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.0.0.ebuild,v 1.1 2005/02/11 13:05:52 usata Exp $
+
+inherit eutils
+
+MY_P="${P/_beta/-b}"
+DESCRIPTION="tiny emacs clone"
+HOMEPAGE="http://zile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zile/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~amd64"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND=">=dev-util/gperf-2.7.2
+ >=sys-apps/texinfo-4.3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ myconf="--enable-all-modes"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ dodir /usr/share/man
+ dodir /usr/share/info
+ keepdir /var/lib/{exrecover,expreserve}
+ make INSTALL=/usr/bin/install \
+ DESTDIR=${D} \
+ MANDIR=/usr/share/man \
+ TERMLIB=termlib \
+ PRESERVEDIR=${D}/var/lib/expreserve \
+ RECOVER="-DEXRECOVER=\\\"/var/lib/exrecover\\\" \
+ -DEXPRESERVE=\\\"/var/lib/expreserve\\\"" \
+ install || die
+
+ dodoc AUTHORS HISTORY KNOWNBUGS NEWS README* TODO
+}