summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-09-26 18:39:43 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-09-26 18:39:43 +0000
commit14c60f9deb4b0eba65a81b1889af0402b14d2011 (patch)
treea075d1184bf0399c679bc137bd37fc0efe283d25 /app-editors/xemacs
parentchanged the digest, no dangerous change of the tarball (warning flag removal) (diff)
downloadgentoo-2-14c60f9deb4b0eba65a81b1889af0402b14d2011.tar.gz
gentoo-2-14c60f9deb4b0eba65a81b1889af0402b14d2011.tar.bz2
gentoo-2-14c60f9deb4b0eba65a81b1889af0402b14d2011.zip
minor version bump. use flag fix. resolves bug #6177
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/ChangeLog9
-rw-r--r--app-editors/xemacs/files/digest-xemacs-21.4.94
-rw-r--r--app-editors/xemacs/xemacs-21.4.9.ebuild154
3 files changed, 166 insertions, 1 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index 4917fef3b143..a88712e285dd 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/xemacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.17 2002/08/08 03:21:15 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.18 2002/09/26 18:39:43 mkennedy Exp $
+
+*xemacs-21.4.9 (26 Sep 2002)
+
+ 26 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ xemacs-21.4.9.ebuild :
+
+ Minor version bump. USE flag fix. Resolves bug #6177.
*xemacs-21.4.8-r3 (28 Jul 2002)
diff --git a/app-editors/xemacs/files/digest-xemacs-21.4.9 b/app-editors/xemacs/files/digest-xemacs-21.4.9
new file mode 100644
index 000000000000..5fbaf2a0c567
--- /dev/null
+++ b/app-editors/xemacs/files/digest-xemacs-21.4.9
@@ -0,0 +1,4 @@
+MD5 d6c159fd4286c29296eacba2c7ee0aa1 xemacs-21.4.9.tar.gz 10577880
+MD5 8c2c6c00cfbdc5f8d64ad54ddfb731df efs-1.29-pkg.tar.gz 371905
+MD5 47ce373c71f658e489767d9880705841 xemacs-base-1.67-pkg.tar.gz 465380
+MD5 d521ca4256a8333db5dc686b9d719232 mule-base-1.42-pkg.tar.gz 443826
diff --git a/app-editors/xemacs/xemacs-21.4.9.ebuild b/app-editors/xemacs/xemacs-21.4.9.ebuild
new file mode 100644
index 000000000000..e6dcec9274ef
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.4.9.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.1 2002/09/26 18:39:43 mkennedy Exp $
+
+# this is just TEMPORARY until we can get to the core of the problem
+SANDBOX_DISABLED="1"
+
+LICENSE="GPL-2"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
+EFS=1.29
+BASE=1.67
+MULE=1.42
+
+SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
+ http://ftp.xemacs.org/packages/efs-${EFS}-pkg.tar.gz
+ http://ftp.xemacs.org/packages/xemacs-base-${BASE}-pkg.tar.gz
+ mule? ( http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz )"
+
+HOMEPAGE="http://www.xemacs.org"
+
+
+RDEPEND="virtual/glibc
+ !virtual/xemacs
+
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6
+ >=media-libs/audiofile-0.2.3
+
+ gpm? ( >=sys-libs/gpm-1.19.6 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+
+ X? ( virtual/x11 >=x11-libs/openmotif-2.1.30 )
+ xface? ( media-libs/compface )
+ tiff? ( media-libs/tiff )
+ png? ( =media-libs/libpng-1.2* )
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ >=sys-libs/ncurses-5.2"
+
+PROVIDE="virtual/xemacs"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ patch -p0 <${FILESDIR}/emodules.info-21.4.8-gentoo.patch || die
+
+ if [ ${ARCH} = "ppc" ] ; then
+ patch -p0 < ${FILESDIR}/${P}-ppc.diff || die
+ fi
+
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X;
+ then
+ myconf="${myconf}
+ --with-x
+ --with-xpm
+ --with-dragndrop
+ --with-gif=no"
+
+ use tiff && myconf="${myconf} --with-tiff" ||
+ myconf="${myconf} --without-tiff"
+ use png && mconf="${myconf} --with-png" ||
+ myconf="${myconf} --without-png"
+ use jpeg && myconf="${myconf} --with-jpeg" ||
+ myconf="${myconf} --without-jpeg"
+ use xface && myconf="${myconf} --with-xface" ||
+ myconf="${myconf} --without-xface"
+
+ myconf="${myconf} --with-dialogs=lucid"
+ myconf="${myconf} --with-widgets=lucid"
+ myconf="${myconf} --with-scrollbars=lucid"
+ myconf="${myconf} --with-menubars=lucid"
+ else
+ myconf="${myconf}
+ --without-x
+ --without-xpm
+ --without-dragndrop
+ --with-gif=no"
+ fi
+
+ use gpm && myconf="${myconf} --with-gpm" ||
+ myconf="${myconf} --without-gpm"
+ use postgres && myconf="${myconf} --with-postgresql" ||
+ myconf="${myconf} --without-postgresql"
+ use mule && myconf="${myconf} --with-mule" ||
+ myconf="${myconf} --without-mule"
+
+ local soundconf="native"
+
+ use nas && soundconf="${soundconf},nas"
+ use esd && soundconf="${soundconf},esd"
+
+ myconf="${myconf} --with-sound=${soundconf}"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --with-database=gnudbm \
+ --with-pop \
+ --with-ncurses \
+ --with-site-lisp=yes \
+ --package-path=/usr/lib/xemacs/xemacs-packages/ \
+ --with-msw=no \
+ || die
+
+ # emake dont work on faster boxes it seems
+ # azarah (04 Aug 2002)
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ infodir=${D}/usr/share/info \
+ install gzip-el || die
+
+ # install base packages
+ dodir /usr/lib/xemacs/xemacs-packages/
+ cd ${D}/usr/lib/xemacs/xemacs-packages/
+ unpack efs-${EFS}-pkg.tar.gz
+ unpack xemacs-base-${BASE}-pkg.tar.gz
+ # (optionally) install mule base package
+ if use mule;
+ then
+ dodir /usr/lib/xemacs/mule-packages
+ cd ${D}/usr/lib/xemacs/mule-packages/
+ unpack mule-base-${MULE}-pkg.tar.gz
+ fi
+
+ # remove extraneous files
+ cd ${D}/usr/share/info
+ rm -f dir info.info texinfo* termcap*
+ cd ${S}
+ dodoc BUGS CHANGES-* COPYING ChangeLog GETTING* INSTALL PROBLEMS README*
+ dodoc ${FILESDIR}/README.Gentoo
+ rm -f ${D}/usr/share/info/emodules.info~*
+}
+