summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-18 03:43:33 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-18 03:43:33 +0000
commit164fab6b1389c182af9962302889a5f856f0268e (patch)
tree6660d978df274393ff8807f03c17734eb0d3cec4 /app-editors/shed
parentUpdate alpha/s390 patches. (diff)
downloadgentoo-2-164fab6b1389c182af9962302889a5f856f0268e.tar.gz
gentoo-2-164fab6b1389c182af9962302889a5f856f0268e.tar.bz2
gentoo-2-164fab6b1389c182af9962302889a5f856f0268e.zip
add prefix support (bug #430098)
(Portage version: 2.2.0_alpha121/cvs/Linux i686)
Diffstat (limited to 'app-editors/shed')
-rw-r--r--app-editors/shed/ChangeLog9
-rw-r--r--app-editors/shed/files/shed-1.15-interix.patch15
-rw-r--r--app-editors/shed/shed-1.15.ebuild12
3 files changed, 30 insertions, 6 deletions
diff --git a/app-editors/shed/ChangeLog b/app-editors/shed/ChangeLog
index dd8456dc0c27..b5ce9e0fb959 100644
--- a/app-editors/shed/ChangeLog
+++ b/app-editors/shed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/shed
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/shed/ChangeLog,v 1.23 2011/08/13 07:01:53 hattya Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/shed/ChangeLog,v 1.24 2012/08/18 03:43:33 ottxor Exp $
+
+ 18 Aug 2012; Christoph Junghans <ottxor@gentoo.org>
+ +files/shed-1.15-interix.patch, shed-1.15.ebuild:
+ add prefix support (bug #430098)
13 Aug 2011; Akinori Hattori <hattya@gentoo.org> shed-1.12.ebuild,
shed-1.13.ebuild:
@@ -78,4 +82,3 @@
shed-1.10.ebuild:
Initial revision. Ebuild submitted by Sven Wegener <sven.wegener@stealer.net>
in bug #41629.
-
diff --git a/app-editors/shed/files/shed-1.15-interix.patch b/app-editors/shed/files/shed-1.15-interix.patch
new file mode 100644
index 000000000000..16c310d91cd1
--- /dev/null
+++ b/app-editors/shed/files/shed-1.15-interix.patch
@@ -0,0 +1,15 @@
+http://sourceforge.net/tracker/?func=detail&aid=3554634&group_id=21862&atid=374571
+diff -ru shed-1.13.orig/shed.c shed-1.13/shed.c
+--- shed-1.13.orig/shed.c 2008-04-03 15:21:53 +0200
++++ shed-1.13/shed.c 2008-04-03 15:23:05 +0200
+@@ -31,6 +31,10 @@
+ #include <ctype.h> /* tolower */
+ #include <unistd.h> /* dup, dup2 */
+
++#ifdef __INTERIX
++# include <sys/time.h>
++#endif
++
+ #include "util.h"
+
+ /* function prototypes */
diff --git a/app-editors/shed/shed-1.15.ebuild b/app-editors/shed/shed-1.15.ebuild
index 3733dd7c6c42..e72ddfc21a63 100644
--- a/app-editors/shed/shed-1.15.ebuild
+++ b/app-editors/shed/shed-1.15.ebuild
@@ -1,21 +1,27 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/shed/shed-1.15.ebuild,v 1.1 2011/08/13 06:33:51 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/shed/shed-1.15.ebuild,v 1.2 2012/08/18 03:43:33 ottxor Exp $
EAPI="4"
+inherit eutils
+
DESCRIPTION="Simple Hex EDitor"
HOMEPAGE="http://shed.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
RDEPEND="sys-libs/ncurses"
DPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-interix.patch
+}
+
src_compile() {
emake AM_CFLAGS="${CFLAGS}"
}