summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-12-27 10:58:57 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-12-27 10:58:57 +0000
commit59ae077af5e957acf9f54a7a366d3b190343e892 (patch)
tree183201de7d5647ea9f50762240638f09d414ac8e /app-editors/scite
parentsign manifest (diff)
downloadgentoo-2-59ae077af5e957acf9f54a7a366d3b190343e892.tar.gz
gentoo-2-59ae077af5e957acf9f54a7a366d3b190343e892.tar.bz2
gentoo-2-59ae077af5e957acf9f54a7a366d3b190343e892.zip
Add patches needed for BSD, see bug #150550.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/ChangeLog6
-rw-r--r--app-editors/scite/files/scite-1.71-install.patch20
-rw-r--r--app-editors/scite/scite-1.71.ebuild6
3 files changed, 29 insertions, 3 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index d6580c2ad867..469e65000a01 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.57 2006/11/04 19:03:07 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.58 2006/12/27 10:58:57 nelchael Exp $
+
+ 27 Dec 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/scite-1.71-install.patch, scite-1.71.ebuild:
+ Add patches needed for BSD, see bug #150550.
04 Nov 2006; Krzysiek Pawlik <nelchael@gentoo.org> -scite-1.70.ebuild:
Remove old version.
diff --git a/app-editors/scite/files/scite-1.71-install.patch b/app-editors/scite/files/scite-1.71-install.patch
new file mode 100644
index 000000000000..c1d87501c855
--- /dev/null
+++ b/app-editors/scite/files/scite-1.71-install.patch
@@ -0,0 +1,20 @@
+--- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
++++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
+@@ -123,11 +123,14 @@
+
+ ifdef gnomeprefix
+ ifdef GTK2
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ else
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ endif
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 644 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/scite-1.71.ebuild b/app-editors/scite/scite-1.71.ebuild
index a80028c31455..74db186e1e23 100644
--- a/app-editors/scite/scite-1.71.ebuild
+++ b/app-editors/scite/scite-1.71.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.71.ebuild,v 1.6 2006/10/31 20:44:41 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.71.ebuild,v 1.7 2006/12/27 10:58:57 nelchael Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
MY_PV=${PV//./}
DESCRIPTION="A very powerful editor for programmers"
@@ -39,7 +39,9 @@ src_unpack() {
-e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
-e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
-e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
|| die "error patching makefile"
+ epatch ${FILESDIR}/${P}-install.patch
}
src_compile() {