summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-01-24 11:33:30 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-01-24 11:33:30 +0000
commit0e0649b4534ee7ec2f8eae7c656942f51d9b64cf (patch)
tree0fe8777ea11d8b024d293d4907cb37913d5be69f /app-editors/scite
parentVersion bump. (diff)
downloadgentoo-2-0e0649b4534ee7ec2f8eae7c656942f51d9b64cf.tar.gz
gentoo-2-0e0649b4534ee7ec2f8eae7c656942f51d9b64cf.tar.bz2
gentoo-2-0e0649b4534ee7ec2f8eae7c656942f51d9b64cf.zip
Version bump.
(Portage version: 2.1.2-r2)
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/ChangeLog10
-rw-r--r--app-editors/scite/files/digest-scite-1.723
-rw-r--r--app-editors/scite/files/scite-1.72-install.patch20
-rw-r--r--app-editors/scite/scite-1.72.ebuild73
4 files changed, 104 insertions, 2 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 469e65000a01..6bb7a38a233f 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.58 2006/12/27 10:58:57 nelchael Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.59 2007/01/24 11:33:30 nelchael Exp $
+
+*scite-1.72 (24 Jan 2007)
+
+ 24 Jan 2007; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/scite-1.72-install.patch, +scite-1.72.ebuild:
+ Version bump.
27 Dec 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+files/scite-1.71-install.patch, scite-1.71.ebuild:
diff --git a/app-editors/scite/files/digest-scite-1.72 b/app-editors/scite/files/digest-scite-1.72
new file mode 100644
index 000000000000..72bebdf84efe
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.72
@@ -0,0 +1,3 @@
+MD5 da4e059117dbd69fb76d87739a98581d scite172.tgz 1335014
+RMD160 7ffcfa07f43560122692bc4bd00bc910167e9082 scite172.tgz 1335014
+SHA256 336c9b93f731882c9c5b95eadbe2751097347113e1d729c49b3e5f85ca4ad42e scite172.tgz 1335014
diff --git a/app-editors/scite/files/scite-1.72-install.patch b/app-editors/scite/files/scite-1.72-install.patch
new file mode 100644
index 000000000000..c1d87501c855
--- /dev/null
+++ b/app-editors/scite/files/scite-1.72-install.patch
@@ -0,0 +1,20 @@
+--- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
++++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
+@@ -123,11 +123,14 @@
+
+ ifdef gnomeprefix
+ ifdef GTK2
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ else
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ endif
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 644 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/scite-1.72.ebuild b/app-editors/scite/scite-1.72.ebuild
new file mode 100644
index 000000000000..6475f4d95e23
--- /dev/null
+++ b/app-editors/scite/scite-1.72.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.72.ebuild,v 1.1 2007/01/24 11:33:30 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://scintilla.sourceforge.net/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ || die "error patching makefile"
+ epatch ${FILESDIR}/${P}-install.patch
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}