summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-30 15:40:32 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-30 15:40:32 +0000
commitb89dae919d8fa8c2be1ecbf46c5e6a0409c51ae7 (patch)
treea024f461273120a6daa2a0fe1c3c4b7e4e260e4c /app-editors/ng
parentMarking openssh-5.1_p1-r1 ppc for bug 231292 (diff)
downloadgentoo-2-b89dae919d8fa8c2be1ecbf46c5e6a0409c51ae7.tar.gz
gentoo-2-b89dae919d8fa8c2be1ecbf46c5e6a0409c51ae7.tar.bz2
gentoo-2-b89dae919d8fa8c2be1ecbf46c5e6a0409c51ae7.zip
Fixed CC variable, bug #243570.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-editors/ng')
-rw-r--r--app-editors/ng/ChangeLog9
-rw-r--r--app-editors/ng/ng-1.5_beta1-r1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/app-editors/ng/ChangeLog b/app-editors/ng/ChangeLog
index d24e86e0962c..cd2562215b25 100644
--- a/app-editors/ng/ChangeLog
+++ b/app-editors/ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/ng
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ChangeLog,v 1.9 2007/10/10 07:12:42 opfer Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ChangeLog,v 1.10 2008/10/30 15:40:32 matsuu Exp $
+
+*ng-1.5_beta1-r1 (30 Oct 2008)
+
+ 30 Oct 2008; MATSUU Takuto <matsuu@gentoo.org> +ng-1.5_beta1-r1.ebuild:
+ Fixed CC variable, bug #243570.
10 Oct 2007; Christian Faulhammer <opfer@gentoo.org> ng-1.5_beta1.ebuild:
remove PROVIDE=virtual/editor as we have now a new-style virtual
diff --git a/app-editors/ng/ng-1.5_beta1-r1.ebuild b/app-editors/ng/ng-1.5_beta1-r1.ebuild
new file mode 100644
index 000000000000..832c38cc0167
--- /dev/null
+++ b/app-editors/ng/ng-1.5_beta1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ng-1.5_beta1-r1.ebuild,v 1.1 2008/10/30 15:40:32 matsuu Exp $
+
+inherit eutils
+
+MY_P="${P/_beta/beta}"
+
+DESCRIPTION="Emacs like micro editor Ng -- based on mg2a"
+HOMEPAGE="http://tt.sakura.ne.jp/~amura/ng/"
+SRC_URI="http://tt.sakura.ne.jp/~amura/archives/ng/${MY_P}.tar.gz"
+
+LICENSE="Emacs"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="canna"
+
+RDEPEND=">=sys-libs/ncurses-5.0
+ canna? ( app-i18n/canna )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${MY_P}-ncurses.patch"
+ sed -i -e "/NO_BACKUP/s/undef/define/" config.h || die "sed failed"
+}
+
+src_compile() {
+ econf $(use_enable canna) || die
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin ng || die
+ dodoc docs/* MANIFEST dot.ng
+
+ insinto /usr/share/ng
+ doins bin/*
+
+ insinto /etc/skel
+ newins dot.ng .ng
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want to use user Config"
+ elog "cp /etc/skel/.ng ~/.ng"
+ elog "and edit your .ng configuration file."
+ elog
+}