summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
commit85bf0780b54b0388919f656d5d2475ac8dfbfc7d (patch)
tree5462eacfdcae74754e7ca88e02f792ab14b385f0 /app-editors/ng
parentversion bump, first gpg-signed package ;) (Manifest recommit) (diff)
downloadgentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.gz
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.bz2
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.zip
dont install uselss COPYING file and fix other stuff while i'm at it
Diffstat (limited to 'app-editors/ng')
-rw-r--r--app-editors/ng/ng-1.5_beta1.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/app-editors/ng/ng-1.5_beta1.ebuild b/app-editors/ng/ng-1.5_beta1.ebuild
index b4368354515e..d8363a3916e1 100644
--- a/app-editors/ng/ng-1.5_beta1.ebuild
+++ b/app-editors/ng/ng-1.5_beta1.ebuild
@@ -1,28 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Id: ng-1.5_beta1.ebuild,v 1.2 2004/05/15 18:47:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ng-1.5_beta1.ebuild,v 1.3 2004/05/31 22:12:03 vapier Exp $
inherit eutils
-IUSE="canna"
-
MY_P=${P/_beta/beta}
DESCRIPTION="Emacs like micro editor Ng -- based on mg2a"
-SRC_URI="http://tt.sakura.ne.jp/~amura/archives/ng/${MY_P}.tar.gz"
-
HOMEPAGE="http://tt.sakura.ne.jp/~amura/ng/"
+SRC_URI="http://tt.sakura.ne.jp/~amura/archives/ng/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="Emacs"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="canna"
-PROVIDE="virtual/editor"
RDEPEND="virtual/glibc
>=sys-libs/ncurses-5.0
canna? ( app-i18n/canna )"
DEPEND="${RDEPEND}
>=sys-apps/sed-4.0"
+PROVIDE="virtual/editor"
S="${WORKDIR}/${MY_P}"
@@ -33,7 +31,6 @@ src_unpack() {
}
src_compile() {
-
local myconf
if use canna; then
@@ -47,9 +44,8 @@ src_compile() {
}
src_install() {
-
- dobin ng
- dodoc docs/* COPYING LICENSE MANIFEST dot.ng
+ dobin ng || die
+ dodoc docs/* MANIFEST dot.ng
insinto /usr/share/ng
doins bin/*
@@ -65,4 +61,3 @@ pkg_postinst() {
einfo "and edit your .ng configuration file."
einfo
}
-