summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-30 16:20:07 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-30 16:20:07 +0000
commitf874645b12f294e31e1c1d72c2d383eb326de2b1 (patch)
tree875d11374528511ff612d498ebe22e2c91832600 /app-editors/nano
parentRemove old (diff)
downloadgentoo-2-f874645b12f294e31e1c1d72c2d383eb326de2b1.tar.gz
gentoo-2-f874645b12f294e31e1c1d72c2d383eb326de2b1.tar.bz2
gentoo-2-f874645b12f294e31e1c1d72c2d383eb326de2b1.zip
buggy
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/nano-2.1.11.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/app-editors/nano/nano-2.1.11.ebuild b/app-editors/nano/nano-2.1.11.ebuild
deleted file mode 100644
index 871acbd4cc97..000000000000
--- a/app-editors/nano/nano-2.1.11.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.11.ebuild,v 1.1 2009/11/02 22:58:23 vapier Exp $
-
-EAPI=2
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
- inherit subversion
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2[unicode?]
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- fi
- cd "${S}"
- epatch "${FILESDIR}"/${P}-proto.patch
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_configure() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml doc/faq.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- einfo "More helpful info about nano, visit the GDP page:"
- einfo "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}