summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-07-15 14:54:58 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-07-15 14:54:58 +0000
commit76e7e0e636a92baa519b64a43f4b805340b61ab3 (patch)
tree3de70bc124065da98af665da554d1420b7b4d715 /app-editors/moe
parentSet USE=graph dependency on net-analyzer/rrdtool (bug #509682). (diff)
downloadgentoo-2-76e7e0e636a92baa519b64a43f4b805340b61ab3.tar.gz
gentoo-2-76e7e0e636a92baa519b64a43f4b805340b61ab3.tar.bz2
gentoo-2-76e7e0e636a92baa519b64a43f4b805340b61ab3.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'app-editors/moe')
-rw-r--r--app-editors/moe/ChangeLog9
-rw-r--r--app-editors/moe/moe-1.6.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/app-editors/moe/ChangeLog b/app-editors/moe/ChangeLog
index 7cb2fc67e19c..ef2db69612c4 100644
--- a/app-editors/moe/ChangeLog
+++ b/app-editors/moe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/moe
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/moe/ChangeLog,v 1.5 2013/06/07 13:05:32 zlogene Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/moe/ChangeLog,v 1.6 2014/07/15 14:54:58 zlogene Exp $
+
+*moe-1.6 (15 Jul 2014)
+
+ 15 Jul 2014; Mikle Kolyada <zlogene@gentoo.org> +moe-1.6.ebuild:
+ Version bump
07 Jun 2013; Mikle Kolyada <zlogene@gentoo.org> moe-1.5.ebuild:
x86 stable wrt bug #472486
diff --git a/app-editors/moe/moe-1.6.ebuild b/app-editors/moe/moe-1.6.ebuild
new file mode 100644
index 000000000000..739bac1f4ee1
--- /dev/null
+++ b/app-editors/moe/moe-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/moe/moe-1.6.ebuild,v 1.1 2014/07/15 14:54:58 zlogene Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="A powerful and user-friendly console text editor"
+HOMEPAGE="http://www.gnu.org/software/moe/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="$(unpacker_src_uri_depends)
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ tc-export CXX
+ sed -i \
+ -e "/^CXXFLAGS=/d" \
+ -e "/^LDFLAGS=/d" \
+ -e "/^CXX=/d" \
+ configure || die "sed on configure failed"
+
+ epatch_user
+}