summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 21:10:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 21:10:10 +0000
commit7d19ddbd17ec86e8f06d8eaf1a7774e2efdebae3 (patch)
treec85a6a8945d8be74b0b6c91c44cf3cc37bdd4dbd /app-editors/leo
parentVersion bump for stable channel release. (diff)
downloadgentoo-2-7d19ddbd17ec86e8f06d8eaf1a7774e2efdebae3.tar.gz
gentoo-2-7d19ddbd17ec86e8f06d8eaf1a7774e2efdebae3.tar.bz2
gentoo-2-7d19ddbd17ec86e8f06d8eaf1a7774e2efdebae3.zip
Version bump.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/leo')
-rw-r--r--app-editors/leo/ChangeLog8
-rw-r--r--app-editors/leo/files/leo-4.8-fix_syntax_errors.patch11
-rw-r--r--app-editors/leo/leo-4.8.ebuild39
3 files changed, 57 insertions, 1 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index a2de178e8478..187ab9931a1f 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/leo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.18 2010/05/28 11:02:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.19 2010/12/13 21:10:09 arfrever Exp $
+
+*leo-4.8 (13 Dec 2010)
+
+ 13 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +leo-4.8.ebuild, +files/leo-4.8-fix_syntax_errors.patch:
+ Version bump.
28 May 2010; Markus Meier <maekke@gentoo.org> leo-4.7.1.ebuild:
x86 stable, bug #315161
diff --git a/app-editors/leo/files/leo-4.8-fix_syntax_errors.patch b/app-editors/leo/files/leo-4.8-fix_syntax_errors.patch
new file mode 100644
index 000000000000..3a13f2d56cdb
--- /dev/null
+++ b/app-editors/leo/files/leo-4.8-fix_syntax_errors.patch
@@ -0,0 +1,11 @@
+--- leo/plugins/old_plugin_manager.py
++++ leo/plugins/old_plugin_manager.py
+@@ -1386,7 +1386,7 @@
+ self.name, directive_text))
+ else:
+ # if isinstance(directive, (str,unicode)):
+- if g.isString(directive)
++ if g.isString(directive):
+ requires.append(directive)
+ else:
+ requires.extend(directive)
diff --git a/app-editors/leo/leo-4.8.ebuild b/app-editors/leo/leo-4.8.ebuild
new file mode 100644
index 000000000000..be7ab4b348ac
--- /dev/null
+++ b/app-editors/leo/leo-4.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.8.ebuild,v 1.1 2010/12/13 21:10:09 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
+
+inherit distutils eutils
+
+MY_P="Leo-${PV}-final"
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-text/silvercity
+ dev-python/PyQt4[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-fix_syntax_errors.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r leo/doc/html/* || die "dohtml failed"
+}