summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-31 17:37:54 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-31 17:37:54 +0000
commit61e468086cba858fd37959046dd65e225fec1843 (patch)
tree8440e1ad1efb2fd8b86b12c201fd2ce098bb381d /app-editors/jed
parentalpha/ia64/sparc stable (diff)
downloadgentoo-2-61e468086cba858fd37959046dd65e225fec1843.tar.gz
gentoo-2-61e468086cba858fd37959046dd65e225fec1843.tar.bz2
gentoo-2-61e468086cba858fd37959046dd65e225fec1843.zip
Version bump. Ebuild cleaned up, EAPI changed to 3. Add prefix keywords.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-editors/jed')
-rw-r--r--app-editors/jed/ChangeLog9
-rw-r--r--app-editors/jed/jed-0.99.19.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/app-editors/jed/ChangeLog b/app-editors/jed/ChangeLog
index 922db5ca07d3..fadccf8bfeeb 100644
--- a/app-editors/jed/ChangeLog
+++ b/app-editors/jed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/jed
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/ChangeLog,v 1.53 2009/01/04 20:15:00 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/ChangeLog,v 1.54 2010/01/31 17:37:54 ulm Exp $
+
+*jed-0.99.19 (31 Jan 2010)
+
+ 31 Jan 2010; Ulrich Mueller <ulm@gentoo.org> +jed-0.99.19.ebuild:
+ Version bump. Ebuild cleaned up, EAPI changed to 3. Add prefix keywords.
04 Jan 2009; Ulrich Mueller <ulm@gentoo.org> jed-0.99.18.ebuild:
Change virtual/xft dependency to x11-libs/libXft, bug 253771.
diff --git a/app-editors/jed/jed-0.99.19.ebuild b/app-editors/jed/jed-0.99.19.ebuild
new file mode 100644
index 000000000000..f1c8ba8c88b8
--- /dev/null
+++ b/app-editors/jed/jed-0.99.19.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.19.ebuild,v 1.1 2010/01/31 17:37:54 ulm Exp $
+
+EAPI=3
+
+inherit versionator
+
+MY_P=${PN}-$(replace_version_separator 2 '-')
+DESCRIPTION="Console S-Lang-based editor"
+HOMEPAGE="http://www.jedsoft.org/jed/"
+SRC_URI="ftp://space.mit.edu/pub/davis/jed/v0.99/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="X gpm xft"
+
+RDEPEND=">=sys-libs/slang-2
+ X? ( x11-libs/libX11
+ xft? ( x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender
+ >=media-libs/freetype-2.0 ) )
+ gpm? ( sys-libs/gpm )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ export JED_ROOT="${EPREFIX}/usr/share/jed"
+ econf \
+ $(use_enable gpm) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ emake || die
+ if use X; then
+ emake xjed || die
+ fi
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+
+ dodoc INSTALL INSTALL.unx README changes.txt || die
+ doinfo info/jed* || die
+
+ insinto /etc
+ doins lib/jed.conf || die
+
+ # replace IDE mode with EMACS mode
+ sed -i -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' \
+ "${ED}"/etc/jed.conf || die "patching jed.conf failed"
+}