summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-06-12 16:29:39 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-06-12 16:29:39 +0000
commit711c11ed048bd217cdbb82000106def1fcf1afff (patch)
treee51b14b638155240ac284ef711d163a8a992be68 /app-editors/gobby
parentbump to rc2 (diff)
downloadgentoo-2-711c11ed048bd217cdbb82000106def1fcf1afff.tar.gz
gentoo-2-711c11ed048bd217cdbb82000106def1fcf1afff.tar.bz2
gentoo-2-711c11ed048bd217cdbb82000106def1fcf1afff.zip
bump to rc2
(Portage version: 2.1)
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/ChangeLog9
-rw-r--r--app-editors/gobby/files/digest-gobby-0.4.0_rc23
-rw-r--r--app-editors/gobby/gobby-0.4.0_rc2.ebuild54
3 files changed, 65 insertions, 1 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index 4394975e1d3d..1e64fda9ca34 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.9 2006/01/23 14:15:32 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.10 2006/06/12 16:29:39 humpback Exp $
+
+*gobby-0.4.0_rc2 (12 Jun 2006)
+
+ 12 Jun 2006; Gustavo Felisberto <humpback@gentoo.org>;
+ +gobby-0.4.0_rc2.ebuild:
+ Added masked 0.4.0_rc2. This packge will not unmasked and should only be
+ used by people wanting to help upstream developers.
23 Jan 2006; Simon Stelling <blubb@gentoo.org> gobby-0.3.0.ebuild:
stable on amd64
diff --git a/app-editors/gobby/files/digest-gobby-0.4.0_rc2 b/app-editors/gobby/files/digest-gobby-0.4.0_rc2
new file mode 100644
index 000000000000..f1926feba2f9
--- /dev/null
+++ b/app-editors/gobby/files/digest-gobby-0.4.0_rc2
@@ -0,0 +1,3 @@
+MD5 6b40cfe48ef9f4d24e4e81486ef6992e gobby-0.4.0rc2.tar.gz 351604
+RMD160 aa1018c8acb943350dad2db31a7a38ceb1ccd3a0 gobby-0.4.0rc2.tar.gz 351604
+SHA256 eb1d4aa4fba2cbe53c82375c72e349d3e950c3c09f644439a06f794e4a74c63a gobby-0.4.0rc2.tar.gz 351604
diff --git a/app-editors/gobby/gobby-0.4.0_rc2.ebuild b/app-editors/gobby/gobby-0.4.0_rc2.ebuild
new file mode 100644
index 000000000000..a4eba19e1665
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.0_rc2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.0_rc2.ebuild,v 1.1 2006/06/12 16:29:39 humpback Exp $
+
+inherit eutils
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://darcs.0x539.de/gobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+SRC_URI="http://releases.0x539.de/${PN}/${P/_/}.tar.gz"
+
+DEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-cpp/gtkmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=net-libs/obby-0.4.0_rc2
+ >=dev-cpp/libxmlpp-2.6
+ >=x11-libs/gtksourceview-1.2.0"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P/_/}
+
+src_compile() {
+ econf --with-gtksourceview `use_with gnome` || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ insinto /usr/share/applications
+ newins ${FILESDIR}/${PN}.desktop-r1 ${PN}.desktop
+}
+
+pkg_postinst() {
+ if built_with_use net-libs/obby howl
+ then
+ einfo "Zeroconf support has been enabled for gobby"
+ else
+ einfo "net-libs/obby was not build with zeroconf support,"
+ einfo "thus zeroconf is not enabled for ${PN}."
+ einfo ""
+ einfo "To get zeroconf support, rebuild net-libs/obby"
+ einfo "with \"howl\" in your USE flags."
+ einfo "Try USE=\"howl\" emerge net-libs/obby app-editors/gobby,"
+ einfo "or add \"howl\" to your USE string in /etc/make.conf and"
+ einfo "emerge net-libs/obby"
+ fi
+}