summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-11-02 09:37:33 +0000
committerUlrich Müller <ulm@gentoo.org>2007-11-02 09:37:33 +0000
commit18764f7d3ecdee78cd8668436b6ba8e651ea83a5 (patch)
tree12561e5f322839f3cc9e961dbb40396b4cc754df /app-editors/emacs/emacs-22.1-r1.ebuild
parentfixed for compiler (bug #197396, thanks Joshua Rich) (diff)
downloadgentoo-2-18764f7d3ecdee78cd8668436b6ba8e651ea83a5.tar.gz
gentoo-2-18764f7d3ecdee78cd8668436b6ba8e651ea83a5.tar.bz2
gentoo-2-18764f7d3ecdee78cd8668436b6ba8e651ea83a5.zip
Partial sync of emacs and emacs-cvs ebuilds.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-editors/emacs/emacs-22.1-r1.ebuild')
-rw-r--r--app-editors/emacs/emacs-22.1-r1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-editors/emacs/emacs-22.1-r1.ebuild b/app-editors/emacs/emacs-22.1-r1.ebuild
index 59b3238f6ac2..2c811ca44ca0 100644
--- a/app-editors/emacs/emacs-22.1-r1.ebuild
+++ b/app-editors/emacs/emacs-22.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.1-r1.ebuild,v 1.15 2007/10/24 09:29:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.1-r1.ebuild,v 1.16 2007/11/02 09:37:33 ulm Exp $
WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="latest"
@@ -97,14 +97,15 @@ src_compile() {
fi
if use X; then
- # GTK+ is the default toolkit if USE=gtk is chosen with other
- # possibilities. Emacs upstream thinks this should be standard
- # policy on all distributions
myconf="${myconf} --with-x"
- myconf="${myconf} $(use_with xpm)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
myconf="${myconf} $(use_with gif) $(use_with png)"
+ myconf="${myconf} $(use_with xpm)"
+
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
if use gtk; then
echo
einfo "Configuring to build with GTK support, disabling all other toolkits"
@@ -175,7 +176,7 @@ src_install () {
doins src/*.[ch]
sed 's/^X//' >00${PN}-${SLOT}-gentoo.el <<-EOF
- ;;; emacs-${SLOT} site-lisp configuration
+ ;;; ${PN}-${SLOT} site-lisp configuration
(if (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
X (setq find-function-C-source-directory
@@ -231,9 +232,9 @@ pkg_postinst() {
echo
elog "You can set the version to be started by /usr/bin/emacs through"
- elog "the Emacs eselect module. Man and info pages are automatically"
- elog "redirected, so you may have several installed Emacs versions at the"
- elog "same time. \"man emacs.eselect\" for details."
+ elog "the Emacs eselect module, which also redirects man and info pages."
+ elog "Therefore, several Emacs versions can be installed at the same time."
+ elog "\"man emacs.eselect\" for details."
}
pkg_postrm() {