summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-01-06 10:41:54 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-01-06 10:41:54 +0000
commit870257589f8bad0b42e45ed069a73b92c4a2fba1 (patch)
tree8fe180f73d7d8537ece6b6174969bd172504b458 /app-editors/elvis
parentvirtual bootloaders in the profiles and virtuals files (diff)
downloadgentoo-2-870257589f8bad0b42e45ed069a73b92c4a2fba1.tar.gz
gentoo-2-870257589f8bad0b42e45ed069a73b92c4a2fba1.tar.bz2
gentoo-2-870257589f8bad0b42e45ed069a73b92c4a2fba1.zip
providing virtual/editor
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/ChangeLog10
-rw-r--r--app-editors/elvis/elvis-2.1.4-r1.ebuild18
-rw-r--r--app-editors/elvis/elvis-2.1.4.ebuild17
3 files changed, 30 insertions, 15 deletions
diff --git a/app-editors/elvis/ChangeLog b/app-editors/elvis/ChangeLog
index 661009d03b23..8cc44948957c 100644
--- a/app-editors/elvis/ChangeLog
+++ b/app-editors/elvis/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for app-editors/elvis
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.4 2002/12/13 10:56:05 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.5 2003/01/06 10:41:54 seemant Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*elvis-2.1.4-r1 (1 Feb 2002)
+ 06 Jan 2003; Seemant Kulleen <seemant@gentoo.org> *.ebuild :
+
+ PROVIDE virtual/editor
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
Added ppc to keywords
diff --git a/app-editors/elvis/elvis-2.1.4-r1.ebuild b/app-editors/elvis/elvis-2.1.4-r1.ebuild
index e00e060cadbb..5b2333511482 100644
--- a/app-editors/elvis/elvis-2.1.4-r1.ebuild
+++ b/app-editors/elvis/elvis-2.1.4-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.11 2002/12/09 04:17:38 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.12 2003/01/06 10:41:54 seemant Exp $
+
+IUSE="X"
MY_P="${PN}-2.1_4"
S=${WORKDIR}/${MY_P}
@@ -11,19 +13,23 @@ HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="x86 ppc sparc "
-IUSE="X"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
+DEPEND=">=sys-libs/ncurses-5.2
X? ( virtual/x11 )"
-RDEPEND=""
+
+PROVIDE="virtual/editor"
src_compile() {
local myconf
use X \
&& myconf="--with-x" \
|| myconf="--without-x"
- ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf} || die
+
+ ./configure \
+ --bindir=${D}/usr/bin \
+ --datadir=${D}/usr/share/elvis \
+ ${myconf} || die
+
cp Makefile Makefile.orig
sed -e "s:gcc -O2:gcc ${CFLAGS}:" Makefile.orig > Makefile
cp config.h config.h.orig
diff --git a/app-editors/elvis/elvis-2.1.4.ebuild b/app-editors/elvis/elvis-2.1.4.ebuild
index 9f91fdf45202..7f87b4297990 100644
--- a/app-editors/elvis/elvis-2.1.4.ebuild
+++ b/app-editors/elvis/elvis-2.1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.10 2002/12/09 04:17:38 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.11 2003/01/06 10:41:54 seemant Exp $
+
+IUSE="X"
MY_P="${PN}-2.1_4"
S=${WORKDIR}/${MY_P}
@@ -11,19 +13,22 @@ HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="x86 ppc sparc "
-IUSE="X"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
+DEPEND=">=sys-libs/ncurses-5.2
X? ( virtual/x11 )"
-RDEPEND=""
+
+PROVIDE="virtual/editor"
src_compile() {
local myconf
use X \
&& myconf="--with-x" \
|| myconf="--without-x"
- ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf} || die
+ ./configure \
+ --bindir=${D}/usr/bin \
+ --datadir=${D}/usr/share/elvis \
+ ${myconf} || die
+
cp Makefile Makefile.orig
cat Makefile.orig | sed -e "s:gcc -O2:gcc ${CFLAGS}:" > Makefile
make || die