summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-06-04 00:07:02 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-06-04 00:07:02 +0000
commit1e3decff04d65e55d3680e653cc0d5a268371d02 (patch)
tree25c4e6f7f154b3331af50a6c505cdabf09a4b4c6 /app-editors/elvis
parentoops, (diff)
downloadgentoo-2-1e3decff04d65e55d3680e653cc0d5a268371d02.tar.gz
gentoo-2-1e3decff04d65e55d3680e653cc0d5a268371d02.tar.bz2
gentoo-2-1e3decff04d65e55d3680e653cc0d5a268371d02.zip
Now finds it's help and configuration files correctly
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/elvis-2.1.4-r1.ebuild44
-rw-r--r--app-editors/elvis/files/digest-elvis-2.1.4-r11
2 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/elvis/elvis-2.1.4-r1.ebuild b/app-editors/elvis/elvis-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..cb332f6425c3
--- /dev/null
+++ b/app-editors/elvis/elvis-2.1.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ryan Tolboom <ryan@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.1 2001/06/04 00:07:02 ryan Exp $
+
+A=elvis-2.1_4.tar.gz
+S=${WORKDIR}/elvis-2.1_4
+DESCRIPTION="A vi/ex clone"
+SRC_URI="ftp://ftp.cs.pdx.edu/pub/elvis/${A}"
+HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ X? ( virtual/x11 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use X`" ]; then
+ mconf="--with-x"
+ else
+ mconf="--without-x"
+ fi
+ try ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf}
+ cp Makefile Makefile.orig
+ sed -e "s:gcc -O2:gcc ${CFLAGS}:" Makefile.orig > Makefile
+ cp config.h config.h.orig
+ sed -e "s:${D}/usr/share/elvis:/usr/share/elvis:" config.h.orig > config.h
+ try make
+
+}
+
+src_install () {
+
+ cp instman.sh instman.sh.orig
+ cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
+ cp insticon.sh insticon.sh.orig
+ cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
+ | sed -e "s:^xlib=.*$:xlib=${D}/usr/lib:" > insticon.sh
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ try make install
+
+}
diff --git a/app-editors/elvis/files/digest-elvis-2.1.4-r1 b/app-editors/elvis/files/digest-elvis-2.1.4-r1
new file mode 100644
index 000000000000..b87166ae8699
--- /dev/null
+++ b/app-editors/elvis/files/digest-elvis-2.1.4-r1
@@ -0,0 +1 @@
+MD5 b5a5040899bdc197e9ccc70a561a6676 elvis-2.1_4.tar.gz