summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-14 03:34:50 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-14 03:34:50 +0000
commitfe0b1094149cd9a6981dec5a391ecca9614faf22 (patch)
tree49375f23bb950b863d16cdd3034cd0c5e6794d61 /app-editors/e3
parentrestored the compressed executable functionality back to the Makefile. (diff)
downloadgentoo-2-fe0b1094149cd9a6981dec5a391ecca9614faf22.tar.gz
gentoo-2-fe0b1094149cd9a6981dec5a391ecca9614faf22.tar.bz2
gentoo-2-fe0b1094149cd9a6981dec5a391ecca9614faf22.zip
changed default mode to pico.
Diffstat (limited to 'app-editors/e3')
-rw-r--r--app-editors/e3/e3-1.7-r1.ebuild9
-rw-r--r--app-editors/e3/files/e3-1.7-r1-gentoo.diff16
2 files changed, 23 insertions, 2 deletions
diff --git a/app-editors/e3/e3-1.7-r1.ebuild b/app-editors/e3/e3-1.7-r1.ebuild
index 5301c70daedf..8f2a7f43062e 100644
--- a/app-editors/e3/e3-1.7-r1.ebuild
+++ b/app-editors/e3/e3-1.7-r1.ebuild
@@ -4,7 +4,7 @@
#
# NOTE: this is an x86-only ebuild!!!
#
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r1.ebuild,v 1.1 2001/08/14 02:12:14 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r1.ebuild,v 1.2 2001/08/14 03:34:50 chadh Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
@@ -12,8 +12,13 @@ SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
HOMEPAGE="http://www.sax.de/~adlibit"
DEPEND="dev-lang/nasm
>=sys-apps/gzip-1.2.4a-r6"
-#RDEPEND=""
+RDEPEND="sys-apps/sed"
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
src_compile() {
try emake
}
diff --git a/app-editors/e3/files/e3-1.7-r1-gentoo.diff b/app-editors/e3/files/e3-1.7-r1-gentoo.diff
new file mode 100644
index 000000000000..097b63b5ee86
--- /dev/null
+++ b/app-editors/e3/files/e3-1.7-r1-gentoo.diff
@@ -0,0 +1,16 @@
+diff -r -C2 e3-1.7.orig/e3.asm e3-1.7/e3.asm
+*** e3-1.7.orig/e3.asm Sun Jul 8 12:31:25 2001
+--- e3-1.7/e3.asm Mon Aug 13 23:25:00 2001
+***************
+*** 23,27 ****
+ %define VI 8
+ %define NE 16
+! %define DEFAULT_MODE WS ;<---- select one of WS, EM, NE, PI, VI
+ %define MAKE_BACKUP
+ %define LESSWRITEOPS
+--- 23,27 ----
+ %define VI 8
+ %define NE 16
+! %define DEFAULT_MODE PI ;<---- select one of WS, EM, NE, PI, VI
+ %define MAKE_BACKUP
+ %define LESSWRITEOPS