summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-02-08 08:47:35 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-02-08 08:47:35 +0000
commit469a9d0dbc372516a6bcf4f1e3a57350d1eeb5eb (patch)
tree576dd749ee8b40de53bec18d6e723dfcfaba42ec /app-doc
parentstable on x86 ; ported to mod-x deps (diff)
downloadgentoo-2-469a9d0dbc372516a6bcf4f1e3a57350d1eeb5eb.tar.gz
gentoo-2-469a9d0dbc372516a6bcf4f1e3a57350d1eeb5eb.tar.bz2
gentoo-2-469a9d0dbc372516a6bcf4f1e3a57350d1eeb5eb.zip
updated all versions with kluge for QT environment lameness
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog7
-rw-r--r--app-doc/doxygen/doxygen-1.4.2.ebuild21
-rw-r--r--app-doc/doxygen/doxygen-1.4.3-r1.ebuild21
-rw-r--r--app-doc/doxygen/doxygen-1.4.4.ebuild21
-rw-r--r--app-doc/doxygen/doxygen-1.4.5.ebuild21
-rw-r--r--app-doc/doxygen/doxygen-1.4.6.ebuild21
6 files changed, 76 insertions, 36 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index b53b8cb8f0d4..79212c187a81 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.93 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.94 2006/02/08 08:47:35 nerdboy Exp $
+
+ 08 Feb 2006; Steve Arnold <nerdboy@gentoo.org> doxygen-1.4.2.ebuild,
+ doxygen-1.4.3-r1.ebuild, doxygen-1.4.4.ebuild, doxygen-1.4.5.ebuild,
+ doxygen-1.4.6.ebuild:
+ updated all versions with kluge for QT environment lameness
28 Jan 2006; Simon Stelling <blubb@gentoo.org>
-files/doxygen-utf8-ru.patch.gz, doxygen-1.4.2.ebuild,
diff --git a/app-doc/doxygen/doxygen-1.4.2.ebuild b/app-doc/doxygen/doxygen-1.4.2.ebuild
index f8b7e130b7b7..588ae9be6264 100644
--- a/app-doc/doxygen/doxygen-1.4.2.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.15 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.16 2006/02/08 08:47:35 nerdboy Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs kde-functions
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -20,6 +20,8 @@ DEPEND="media-gfx/graphviz
virtual/ghostscript
>=sys-apps/sed-4"
+if use qt; then need-qt 3; fi
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -47,13 +49,18 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
- export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
- my_conf="${my_conf} $(use_with qt doxywizard)"
+ einfo "using QT version: '$QTVER'."
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
fi
- # ./configure and compile
- ./configure ${my_conf} || die '"./configure" failed.'
+ # and compile
make DESTDIR="${D}" all || die '"make all" failed.'
# generate html and pdf (if tetex in use) documents.
diff --git a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
index 815d699fcc84..26ed024f7c9c 100644
--- a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.10 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.11 2006/02/08 08:47:35 nerdboy Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs kde-functions
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -21,6 +21,8 @@ RDEPEND="media-gfx/graphviz
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
+if use qt; then need-qt 3; fi
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -51,13 +53,18 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
- export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
- my_conf="${my_conf} $(use_with qt doxywizard)"
+ einfo "using QT version: '$QTVER'."
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
fi
- # ./configure and compile
- ./configure ${my_conf} || die '"./configure" failed.'
+ # and compile
emake all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.
diff --git a/app-doc/doxygen/doxygen-1.4.4.ebuild b/app-doc/doxygen/doxygen-1.4.4.ebuild
index 661f2a61738d..d18ed47d9a97 100644
--- a/app-doc/doxygen/doxygen-1.4.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.4.ebuild,v 1.16 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.4.ebuild,v 1.17 2006/02/08 08:47:35 nerdboy Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs kde-functions
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -21,6 +21,8 @@ RDEPEND="media-gfx/graphviz
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
+if use qt; then need-qt 3; fi
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -45,13 +47,18 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
- export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
- my_conf="${my_conf} $(use_with qt doxywizard)"
+ einfo "using QT version: '$QTVER'."
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
fi
- # ./configure and compile
- ./configure ${my_conf} || die '"./configure" failed.'
+ # and compile
emake all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.
diff --git a/app-doc/doxygen/doxygen-1.4.5.ebuild b/app-doc/doxygen/doxygen-1.4.5.ebuild
index a773c0b46dc3..76447af80cbd 100644
--- a/app-doc/doxygen/doxygen-1.4.5.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.5.ebuild,v 1.5 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.5.ebuild,v 1.6 2006/02/08 08:47:35 nerdboy Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs kde-functions
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -21,6 +21,8 @@ RDEPEND=">=media-gfx/graphviz-2.6
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
+if use qt; then need-qt 3; fi
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -45,13 +47,18 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
- export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
- my_conf="${my_conf} $(use_with qt doxywizard)"
+ einfo "using QT version: '$QTVER'."
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
fi
- # ./configure and compile
- ./configure ${my_conf} || die '"configure" failed.'
+ # and compile
emake all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.
diff --git a/app-doc/doxygen/doxygen-1.4.6.ebuild b/app-doc/doxygen/doxygen-1.4.6.ebuild
index 5500ee1f5286..a3a02c81f566 100644
--- a/app-doc/doxygen/doxygen-1.4.6.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.6.ebuild,v 1.2 2006/01/29 15:41:41 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.6.ebuild,v 1.3 2006/02/08 08:47:35 nerdboy Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs kde-functions
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -21,6 +21,8 @@ RDEPEND=">=media-gfx/graphviz-2.6
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
+if use qt; then need-qt 3; fi
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -45,13 +47,18 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
- export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
- my_conf="${my_conf} $(use_with qt doxywizard)"
+ einfo "using QT version: '$QTVER'."
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
fi
- # ./configure and compile
- ./configure ${my_conf} || die '"configure" failed.'
+ # and compile
emake all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.