summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-02 03:32:22 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-02 03:32:22 +0000
commit218da8fa18b0100b04a627c097fd39007f375703 (patch)
tree827070e51c2efe90b68cf21c3c71bd735236eb95 /app-doc
parentVersion bump. (diff)
downloadgentoo-2-218da8fa18b0100b04a627c097fd39007f375703.tar.gz
gentoo-2-218da8fa18b0100b04a627c097fd39007f375703.tar.bz2
gentoo-2-218da8fa18b0100b04a627c097fd39007f375703.zip
Version bump.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/csound-manual/ChangeLog7
-rw-r--r--app-doc/csound-manual/csound-manual-5.18.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-doc/csound-manual/ChangeLog b/app-doc/csound-manual/ChangeLog
index 010a15f20053..c3f1be47bf73 100644
--- a/app-doc/csound-manual/ChangeLog
+++ b/app-doc/csound-manual/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/csound-manual
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/csound-manual/ChangeLog,v 1.1 2012/04/11 22:16:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/csound-manual/ChangeLog,v 1.2 2012/09/02 03:32:22 radhermit Exp $
+
+*csound-manual-5.18 (02 Sep 2012)
+
+ 02 Sep 2012; Tim Harder <radhermit@gentoo.org> +csound-manual-5.18.ebuild:
+ Version bump.
*csound-manual-5.17 (11 Apr 2012)
diff --git a/app-doc/csound-manual/csound-manual-5.18.ebuild b/app-doc/csound-manual/csound-manual-5.18.ebuild
new file mode 100644
index 000000000000..4b144af7bff2
--- /dev/null
+++ b/app-doc/csound-manual/csound-manual-5.18.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/csound-manual/csound-manual-5.18.ebuild,v 1.1 2012/09/02 03:32:22 radhermit Exp $
+
+EAPI="4"
+
+MY_P="Csound${PV}"
+
+DESCRIPTION="The Csound reference manual"
+HOMEPAGE="http://csounds.com/"
+SRC_URI="
+ mirror://sourceforge/csound/${MY_P}_manual_pdf.zip
+ linguas_fr? ( mirror://sourceforge/csound/${MY_P}_manual-fr_pdf.zip )
+
+ html? (
+ mirror://sourceforge/csound/${MY_P}_manual_html.zip
+ linguas_fr? ( mirror://sourceforge/csound/${MY_P}_manual-fr_html.zip )
+ )"
+
+LICENSE="FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="html"
+
+LANGS=" fr"
+IUSE+="${LANGS// / linguas_}"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${MY_P}_manual_pdf.zip
+
+ if use html ; then
+ unpack ${MY_P}_manual_html.zip
+ mv html html-en
+ fi
+
+ local lang
+ for lang in ${LANGS} ; do
+ use linguas_${lang} || continue
+ unpack ${MY_P}_manual-${lang}_pdf.zip
+ if use html ; then
+ unpack ${MY_P}_manual-${lang}_html.zip
+ mv html html-${lang}
+ fi
+ done
+}
+
+src_install() {
+ dodoc *.pdf
+
+ if use html ; then
+ dohtml -r html-en/*
+
+ local lang
+ for lang in ${LANGS} ; do
+ use linguas_${lang} || continue
+ docinto html-${lang}
+ dohtml -r html-${lang}/*
+ done
+ fi
+}