summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-03-09 17:13:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-03-09 17:13:03 +0000
commit03419aaa507c995e1cce2186eb2dcc9f5f382283 (patch)
treee5c1e7e8956c8f6d051842436db599bbebaa7d09 /app-doc
parentdepend on ounit, not type-conv... bug #460628 by Alexandru Scvortov (diff)
downloadgentoo-2-03419aaa507c995e1cce2186eb2dcc9f5f382283.tar.gz
gentoo-2-03419aaa507c995e1cce2186eb2dcc9f5f382283.tar.bz2
gentoo-2-03419aaa507c995e1cce2186eb2dcc9f5f382283.zip
Add snapshot ebuild per #460084
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/devmanual/ChangeLog8
-rw-r--r--app-doc/devmanual/devmanual-0_pre20130309.ebuild49
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild6
3 files changed, 60 insertions, 3 deletions
diff --git a/app-doc/devmanual/ChangeLog b/app-doc/devmanual/ChangeLog
index eeb906d707d8..ada2f04c7789 100644
--- a/app-doc/devmanual/ChangeLog
+++ b/app-doc/devmanual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/devmanual
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/ChangeLog,v 1.6 2013/02/26 18:31:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/ChangeLog,v 1.7 2013/03/09 17:13:03 hwoarang Exp $
+
+*devmanual-0_pre20130309 (09 Mar 2013)
+
+ 09 Mar 2013; Markos Chandras <hwoarang@gentoo.org>
+ +devmanual-0_pre20130309.ebuild, devmanual-9999.ebuild:
+ Add snapshot ebuild per #460084
26 Feb 2013; Markos Chandras <hwoarang@gentoo.org> devmanual-9999.ebuild:
Typo
diff --git a/app-doc/devmanual/devmanual-0_pre20130309.ebuild b/app-doc/devmanual/devmanual-0_pre20130309.ebuild
new file mode 100644
index 000000000000..3195c45cf412
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20130309.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-0_pre20130309.ebuild,v 1.1 2013/03/09 17:13:03 hwoarang Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+[[ "${PV}" == "9999" ]] && inherit git-2
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="http://devmanual.gentoo.org/"
+if [[ "${PV}" == "9999" ]]; then
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/devmanual.git"
+else
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+fi
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libxslt
+ media-gfx/imagemagick[truetype]"
+
+DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ /usr/share/doc/devmanual/html/index.html"
+
+src_install() {
+ dohtml -r *
+ einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"
+ dosym /usr/share/doc/${P} /usr/share/doc/${PN}
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version app-portage/eclass-manpages; then
+ elog "The offline version of the devmanual does not include the"
+ elog "documentation for the eclasses. If you need it, then emerge"
+ elog "the following package:"
+ elog
+ elog "app-portage/eclass-manpages"
+ elog
+ fi
+}
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 0ebd9543f90b..88b87e41fc17 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-9999.ebuild,v 1.6 2013/02/26 18:31:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-9999.ebuild,v 1.7 2013/03/09 17:13:03 hwoarang Exp $
EAPI=5
@@ -22,10 +22,12 @@ DEPEND="dev-libs/libxslt
DOC_CONTENTS="In order to browse the Gentoo Development Guide in
offline mode, point your browser to the following url:
- /usr/share/doc/devmanual-9999/html/index.html"
+ /usr/share/doc/devmanual/html/index.html"
src_install() {
dohtml -r *
+ einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"
+ dosym /usr/share/doc/${P} /usr/share/doc/${PN}
readme.gentoo_create_doc
}