summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-23 18:46:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-23 18:46:45 +0000
commitb0ea94e2eb97133677905c41c714304d6c7e50c0 (patch)
treeb66a538da12ab425f96ecf9b40e5e9c8608744f8 /app-dicts/kasumi
parentStable on sparc (diff)
downloadgentoo-2-b0ea94e2eb97133677905c41c714304d6c7e50c0.tar.gz
gentoo-2-b0ea94e2eb97133677905c41c714304d6c7e50c0.tar.bz2
gentoo-2-b0ea94e2eb97133677905c41c714304d6c7e50c0.zip
Fix quoting, add die messages, use emake for install, add missing dependency on anthy.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'app-dicts/kasumi')
-rw-r--r--app-dicts/kasumi/ChangeLog6
-rw-r--r--app-dicts/kasumi/kasumi-2.0.ebuild15
2 files changed, 13 insertions, 8 deletions
diff --git a/app-dicts/kasumi/ChangeLog b/app-dicts/kasumi/ChangeLog
index c088d517d059..7fd5fe32fe51 100644
--- a/app-dicts/kasumi/ChangeLog
+++ b/app-dicts/kasumi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-dicts/kasumi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.19 2006/06/22 12:30:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.20 2006/06/23 18:46:45 flameeyes Exp $
+
+ 23 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> kasumi-2.0.ebuild:
+ Fix quoting, add die messages, use emake for install, add missing dependency
+ on anthy.
22 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate manifest.
diff --git a/app-dicts/kasumi/kasumi-2.0.ebuild b/app-dicts/kasumi/kasumi-2.0.ebuild
index 51181ad6f4ee..7976557324b1 100644
--- a/app-dicts/kasumi/kasumi-2.0.ebuild
+++ b/app-dicts/kasumi/kasumi-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.0.ebuild,v 1.1 2006/06/21 01:09:19 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.0.ebuild,v 1.2 2006/06/23 18:46:45 flameeyes Exp $
inherit eutils
@@ -19,24 +19,25 @@ RDEPEND=">=x11-libs/gtk+-2.2
>=dev-libs/atk-1.4
>=dev-libs/expat-1.95
>=x11-libs/pango-1.2
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+ app-i18n/anthy"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc41.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc41.patch"
}
src_compile() {
- econf $(use_enable nls) || die
- emake || die
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc README ChangeLog AUTHORS
}