summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-07-08 01:04:45 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-07-08 01:04:45 +0000
commite02d62b22e6275ac5022c6901b861fa24673ac24 (patch)
treee246890bf0ec20de7c620e9488b01263cd853c0f /app-crypt
parentRemove old. (diff)
downloadgentoo-2-e02d62b22e6275ac5022c6901b861fa24673ac24.tar.gz
gentoo-2-e02d62b22e6275ac5022c6901b861fa24673ac24.tar.bz2
gentoo-2-e02d62b22e6275ac5022c6901b861fa24673ac24.zip
rev bump to add slot dependency on dev-lang/go
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/etcd-ca/ChangeLog8
-rw-r--r--app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/app-crypt/etcd-ca/ChangeLog b/app-crypt/etcd-ca/ChangeLog
index a16edd23087b..b72e54ac02b7 100644
--- a/app-crypt/etcd-ca/ChangeLog
+++ b/app-crypt/etcd-ca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/etcd-ca
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/etcd-ca/ChangeLog,v 1.3 2015/06/05 12:03:55 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/etcd-ca/ChangeLog,v 1.4 2015/07/08 01:04:45 williamh Exp $
+
+*etcd-ca-0_p20150423-r1 (08 Jul 2015)
+
+ 08 Jul 2015; William Hubbs <williamh@gentoo.org>
+ +etcd-ca-0_p20150423-r1.ebuild:
+ rev bump to add slot dependency on dev-lang/go
05 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild b/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild
new file mode 100644
index 000000000000..da8512cdeca3
--- /dev/null
+++ b/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/etcd-ca/etcd-ca-0_p20150423-r1.ebuild,v 1.1 2015/07/08 01:04:45 williamh Exp $
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="A simple certificate manager written in Go. Easy to use with limited capability"
+HOMEPAGE="https://github.com/coreos/etcd-ca"
+EGIT_COMMIT="31fef42f75294cf8bf1e7facf82648de0c2d87a3"
+SRC_URI="${HOMEPAGE}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.2:="
+RDEPEND=""
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+# go tool: no such tool "cover"; to install:
+# go get code.google.com/p/go.tools/cmd/cover
+#src_test() {
+# ./test || die
+#}
+
+src_install() {
+ dobin "${S}"/bin/${PN}
+ dodoc README.md
+ use doc && dodoc -r Documentation
+}