summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-06-12 11:04:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-06-12 11:04:32 +0000
commita8054bc6b4d23fbaee8f72619d1b125fc6bec041 (patch)
tree41bf6fe8b54c762ea15c17da3ef87184b9eb5439 /app-crypt
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-a8054bc6b4d23fbaee8f72619d1b125fc6bec041.tar.gz
gentoo-2-a8054bc6b4d23fbaee8f72619d1b125fc6bec041.tar.bz2
gentoo-2-a8054bc6b4d23fbaee8f72619d1b125fc6bec041.zip
Actualy fix the deps to be correct. Dependency on debug is never = but only ?. Also block correct slot not only <x because it would fail when there is some new revbump. Also move that blocker to rdep, where all blocks should be (binary packages).
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/ChangeLog10
-rw-r--r--app-crypt/qca/qca-2.0.2-r2.ebuild61
2 files changed, 70 insertions, 1 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 9946f7393a2c..8eada9711f02 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.65 2009/06/10 20:17:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.66 2009/06/12 11:04:32 scarabeus Exp $
+
+*qca-2.0.2-r2 (12 Jun 2009)
+
+ 12 Jun 2009; Tomáš Chvátal <scarabeus@gentoo.org> +qca-2.0.2-r2.ebuild:
+ Actualy fix the deps to be correct. Dependency on debug is never = but
+ only ?. Also block correct slot not only <x because it would fail when
+ there is some new revbump. Also move that blocker to rdep, where all
+ blocks should be (binary packages).
10 Jun 2009; Markus Meier <maekke@gentoo.org> qca-2.0.2-r1.ebuild:
amd64/x86 stable, bug #272865
diff --git a/app-crypt/qca/qca-2.0.2-r2.ebuild b/app-crypt/qca/qca-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..98bb0642cf67
--- /dev/null
+++ b/app-crypt/qca/qca-2.0.2-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.2-r2.ebuild,v 1.1 2009/06/12 11:04:32 scarabeus Exp $
+
+EAPI="2"
+
+inherit eutils multilib qt4
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+RESTRICT="test"
+
+DEPEND="x11-libs/qt-core:4[debug?]"
+RDEPEND="${DEPEND}
+ !app-crypt/qca:0
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pcfilespath.patch
+}
+
+src_configure() {
+ _libdir=$(get_libdir)
+
+ ./configure \
+ --prefix=/usr \
+ --qtdir=/usr \
+ --includedir="/usr/include/qca2" \
+ --libdir="/usr/${_libdir}/qca2" \
+ --no-separate-debug-info \
+ --disable-tests \
+ --$(use debug && echo debug || echo release) \
+ || die "configure failed"
+
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README TODO || die "dodoc failed"
+
+ cat <<-EOF > "${WORKDIR}"/44qca2
+ LDPATH=/usr/${_libdir}/qca2
+ EOF
+ doenvd "${WORKDIR}"/44qca2 || die
+
+ if use doc; then
+ dohtml "${S}"/apidocs/html/* || die "Failed to install documentation"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r "${S}"/examples || die "Failed to install examples"
+ fi
+}