summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-12-15 20:59:11 +0000
committerDane Smith <c1pher@gentoo.org>2010-12-15 20:59:11 +0000
commit755742ab6154895bd1a01e740cf29ce31a7381b2 (patch)
treedb02882cc1cd32759f6045eabb4aec4b7b7a1d32 /app-crypt/truecrypt
parentversion bump (diff)
downloadgentoo-2-755742ab6154895bd1a01e740cf29ce31a7381b2.tar.gz
gentoo-2-755742ab6154895bd1a01e740cf29ce31a7381b2.tar.bz2
gentoo-2-755742ab6154895bd1a01e740cf29ce31a7381b2.zip
Revbump for truecrypt. Adds init script for baselayout-2 wrt bug 302170.
(Portage version: 2.2.0_alpha4/cvs/Linux i686)
Diffstat (limited to 'app-crypt/truecrypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog11
-rw-r--r--app-crypt/truecrypt/files/truecrypt.init29
-rw-r--r--app-crypt/truecrypt/metadata.xml3
-rw-r--r--app-crypt/truecrypt/truecrypt-7.0a-r2.ebuild122
4 files changed, 163 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 5ad02ed0a6cd..364b93eecd1c 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.57 2010/11/07 14:45:38 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.58 2010/12/15 20:59:11 c1pher Exp $
+
+*truecrypt-7.0a-r2 (15 Dec 2010)
+
+ 15 Dec 2010; Dane Smith <c1pher@gentoo.org> +truecrypt-7.0a-r2.ebuild,
+ +files/truecrypt.init, metadata.xml:
+ Revbump to 7.0a-r2
+ *Adds init script for baselayout-2 wrt bug 302170.
+ *Ebuild cleanup and documenting.
+ *Added myself as a maintainer in metadata.
07 Nov 2010; Dane Smith <c1pher@gentoo.org> truecrypt-7.0a-r1.ebuild:
Removed the fetch restrict. Note for future version bumps: the source
diff --git a/app-crypt/truecrypt/files/truecrypt.init b/app-crypt/truecrypt/files/truecrypt.init
new file mode 100644
index 000000000000..2d861f66e47d
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt.init
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/files/truecrypt.init,v 1.1 2010/12/15 20:59:11 c1pher Exp $
+
+depend() {
+ after localmount
+ if [ -e /lib/librc.so ]; then
+ need device-mapper
+ fi
+}
+
+start() {
+ if [ ! -e /lib/librc.so ]; then
+ eerror "The ${myservice} init script is written for baselayout-2"
+ eerror "Please do not use it with baselayout-1"
+ return 1
+ fi
+}
+
+stop() {
+ if [ ! -e /lib/librc.so ]; then
+ eerror "The ${myservice} init script is written for baselayout-2"
+ eerror "Please do not use it with baselayout-1"
+ return 1
+ fi
+
+ . /lib/rcscripts/addons/truecrypt-stop.sh
+}
diff --git a/app-crypt/truecrypt/metadata.xml b/app-crypt/truecrypt/metadata.xml
index df1a1a8242fe..432920121fe0 100644
--- a/app-crypt/truecrypt/metadata.xml
+++ b/app-crypt/truecrypt/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>crypto</herd>
<maintainer>
- <email>crypto@gentoo.org</email>
+ <email>c1pher@gentoo.org</email>
+ <name>Dane Smith</name>
</maintainer>
</pkgmetadata>
diff --git a/app-crypt/truecrypt/truecrypt-7.0a-r2.ebuild b/app-crypt/truecrypt/truecrypt-7.0a-r2.ebuild
new file mode 100644
index 000000000000..1715584237da
--- /dev/null
+++ b/app-crypt/truecrypt/truecrypt-7.0a-r2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.0a-r2.ebuild,v 1.1 2010/12/15 20:59:11 c1pher Exp $
+
+EAPI="2"
+
+inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets eutils
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="truecrypt-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+RESTRICT="bindist"
+
+RDEPEND="|| ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper )
+ sys-fs/fuse
+ x11-libs/wxGTK:2.8[X?]"
+DEPEND="${RDEPEND}
+ || ( dev-libs/pkcs11-helper dev-libs/opensc )"
+RDEPEND="${RDEPEND}
+ app-admin/sudo"
+
+S="${WORKDIR}/${P}-source"
+
+#No longer in use as truecrypt is on the Gentoo Mirrors
+#NOTE: It needs to be manually updated every time we version bump.
+#pkg_nofetch() {
+# elog "Please download .tar.gz source from:"
+# elog "http://www.truecrypt.org/downloads2"
+# elog "Then put the file in ${DISTDIR}/${P}.tar.gz"
+#}
+
+pkg_setup() {
+ local CONFIG_CHECK="~BLK_DEV_DM ~DM_CRYPT ~FUSE_FS ~CRYPTO ~CRYPTO_XTS"
+ linux-info_pkg_setup
+
+ local WX_GTK_VER="2.8"
+ if use X; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+}
+
+src_prepare() {
+ if has_version x11-libs/wxGTK[X]; then
+ # Fix linking when NOGUI=1
+ sed -e "s/WX_CONFIG_LIBS := base/&,core/" -i Main/Main.make || die "sed Main/Main.make failed"
+ fi
+}
+
+src_compile() {
+ local EXTRA pkcs11_include_directory
+
+ use X || EXTRA+=" NOGUI=1"
+
+ if has_version dev-libs/pkcs11-helper; then
+ pkcs11_include_directory="/usr/include/pkcs11-helper-1.0"
+ else
+ pkcs11_include_directory="/usr/include/opensc"
+ fi
+ append-flags -DCKR_NEW_PIN_MODE=0x000001B0 -DCKR_NEXT_OTP=0x000001B1
+
+ emake \
+ ${EXTRA} \
+ NOSTRIP=1 \
+ NOTEST=1 \
+ VERBOSE=1 \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ TC_EXTRA_CFLAGS="${CFLAGS}" \
+ TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ TC_EXTRA_LFLAGS="${LDFLAGS}" \
+ WX_CONFIG="${WX_CONFIG}" \
+ PKCS11_INC="${pkcs11_include_directory}" \
+ || die "emake failed"
+}
+
+src_test() {
+ "${S}/Main/truecrypt" --text --test || die "tests failed"
+}
+
+src_install() {
+ dobin Main/truecrypt || die
+ dodoc Readme.txt "Release/Setup Files/TrueCrypt User Guide.pdf" || die
+ exeinto "/$(get_libdir)/rcscripts/addons"
+ newexe "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh" || die
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN} || die
+
+ if use X; then
+ newicon Resources/Icons/TrueCrypt-48x48.xpm truecrypt.xpm || die
+ make_desktop_entry ${PN} "TrueCrypt" ${PN} "System" || die
+ fi
+}
+
+pkg_postinst() {
+ elog "There is now an init script for TrueCrypt for Baselayout-2."
+ elog "If you are a baselayout-2 user and you would like the TrueCrypt"
+ elog "mappings removed on shutdown in order to prevent other file systems"
+ elog "from unmounting then run:"
+ elog "rc-update truecrypt boot"
+ elog ""
+
+ ewarn "If you're getting errors about DISPLAY while using the terminal"
+ ewarn "it's a known upstream bug. To use TrueCrypt from the terminal"
+ ewarn "all that's necessary is to run: unset DISPLAY"
+ ewarn "This will make the display unaccessable from that terminal "
+ ewarn "but at least you will be able to access your volumes."
+ ewarn ""
+
+ ewarn "TrueCrypt has very restrictive license."
+ ewarn "Please read the ${LICENSE} license in ${PORTDIR}/licenses"
+ ewarn "directory before using TrueCrypt. Please be explicitly aware of"
+ ewarn "the limitations on redistribution of binaries or modified source."
+}