summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-09-16 17:26:31 +0000
committerSven Wegener <swegener@gentoo.org>2006-09-16 17:26:31 +0000
commit2da38ade8bd2638d1e2a11682f46e97fa6d356c6 (patch)
tree31a534cdecfd34320478ab1940c6943c2c32df64 /app-crypt/sign
parentAs-needed fixes (diff)
downloadgentoo-2-2da38ade8bd2638d1e2a11682f46e97fa6d356c6.tar.gz
gentoo-2-2da38ade8bd2638d1e2a11682f46e97fa6d356c6.tar.bz2
gentoo-2-2da38ade8bd2638d1e2a11682f46e97fa6d356c6.zip
Add support for --as-needed and openssl-0.9.8.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'app-crypt/sign')
-rw-r--r--app-crypt/sign/ChangeLog11
-rw-r--r--app-crypt/sign/files/1.0.7-as-needed.patch10
-rw-r--r--app-crypt/sign/files/1.0.7-openssl-0.9.8.patch12
-rw-r--r--app-crypt/sign/files/digest-sign-1.0.72
-rw-r--r--app-crypt/sign/sign-1.0.7.ebuild14
5 files changed, 43 insertions, 6 deletions
diff --git a/app-crypt/sign/ChangeLog b/app-crypt/sign/ChangeLog
index 377821de5b9b..999d4978823f 100644
--- a/app-crypt/sign/ChangeLog
+++ b/app-crypt/sign/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-crypt/sign
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/sign/ChangeLog,v 1.10 2005/09/20 19:15:35 grobian Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/sign/ChangeLog,v 1.11 2006/09/16 17:26:31 swegener Exp $
+
+ 16 Sep 2006; Sven Wegener <swegener@gentoo.org>
+ +files/1.0.7-openssl-0.9.8.patch, +files/1.0.7-as-needed.patch,
+ sign-1.0.7.ebuild:
+ Add support for --as-needed and openssl-0.9.8.
20 Sep 2005; Fabian Groffen <grobian@gentoo.org> sign-1.0.7.ebuild:
- Markgin ~ppc-macos (bug #106614)
+ Marking ~ppc-macos (bug #106614)
16 May 2005; Sven Wegener <swegener@gentoo.org> sign-1.0.7.ebuild:
Added cross-compile support.
diff --git a/app-crypt/sign/files/1.0.7-as-needed.patch b/app-crypt/sign/files/1.0.7-as-needed.patch
new file mode 100644
index 000000000000..56574d7131d7
--- /dev/null
+++ b/app-crypt/sign/files/1.0.7-as-needed.patch
@@ -0,0 +1,10 @@
+diff -Nur sign-1.0.7.orig/src/Makefile sign-1.0.7/src/Makefile
+--- sign-1.0.7.orig/src/Makefile 2004-08-07 07:15:00.000000000 +0000
++++ sign-1.0.7/src/Makefile 2006-09-16 17:21:12.400977608 +0000
+@@ -1,5 +1,5 @@
+ CFLAGS += -Wall -DNDEBUG -g
+-LDFLAGS += -lcrypto
++LDLIBS += -lcrypto
+
+ OBJS = buf.o die.o msg.o digest.o uue.o pki.o str.o system-nix.o \
+ system-nix-readpass.o util.o
diff --git a/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
new file mode 100644
index 000000000000..179efbe77ef5
--- /dev/null
+++ b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
@@ -0,0 +1,12 @@
+diff -Nur sign-1.0.7.orig/src/pki.c sign-1.0.7/src/pki.c
+--- sign-1.0.7.orig/src/pki.c 2004-08-04 04:10:35.000000000 +0000
++++ sign-1.0.7/src/pki.c 2006-09-16 17:17:34.335535125 +0000
+@@ -286,7 +286,7 @@
+
+ /* if it's not a decryption problem - bail out */
+ if (ERR_get_error() != ERR_PACK(ERR_LIB_EVP,
+- EVP_F_EVP_DECRYPTFINAL,
++ EVP_F_EVP_DECRYPTFINAL_EX,
+ EVP_R_BAD_DECRYPT))
+ goto cleanup;
+
diff --git a/app-crypt/sign/files/digest-sign-1.0.7 b/app-crypt/sign/files/digest-sign-1.0.7
index d499546cdf98..8ffafa6e73ac 100644
--- a/app-crypt/sign/files/digest-sign-1.0.7
+++ b/app-crypt/sign/files/digest-sign-1.0.7
@@ -1 +1,3 @@
MD5 f01c3f5dffc80d3ccd096d039e0c94f1 sign-1.0.7.tar.gz 28535
+RMD160 cebad14a3c68bd103bf790ae054c1497c2ce3853 sign-1.0.7.tar.gz 28535
+SHA256 c5f005eff29880807af37a128724f064cccb166fc9f49acab5f1403c9b72d4b9 sign-1.0.7.tar.gz 28535
diff --git a/app-crypt/sign/sign-1.0.7.ebuild b/app-crypt/sign/sign-1.0.7.ebuild
index a5ecefa7c664..6034ea843305 100644
--- a/app-crypt/sign/sign-1.0.7.ebuild
+++ b/app-crypt/sign/sign-1.0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/sign/sign-1.0.7.ebuild,v 1.6 2005/09/20 19:15:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/sign/sign-1.0.7.ebuild,v 1.7 2006/09/16 17:26:31 swegener Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="File signing and signature verification utility"
HOMEPAGE="http://swapped.cc/sign/"
@@ -14,6 +14,14 @@ IUSE=""
DEPEND=">=dev-libs/openssl-0.9.6"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ has_version ">=dev-libs/openssl-0.9.8" && epatch "${FILESDIR}"/${PV}-openssl-0.9.8.patch
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+}
+
src_compile() {
emake CC="$(tc-getCC)" || die "emake failed"
}