summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-06 01:34:03 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-06 01:34:03 +0000
commitd5f1e0022423cda2ebfd46160e8c7fa036920100 (patch)
tree4697bcd6595d15e0ea68f9bfb630bbd338436310 /app-crypt/qca
parentFix compilation problems with not finding speech-tools... closes bug #76810. (diff)
downloadgentoo-2-d5f1e0022423cda2ebfd46160e8c7fa036920100.tar.gz
gentoo-2-d5f1e0022423cda2ebfd46160e8c7fa036920100.tar.bz2
gentoo-2-d5f1e0022423cda2ebfd46160e8c7fa036920100.zip
multilib fixes.
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog6
-rw-r--r--app-crypt/qca/qca-1.0-r1.ebuild5
-rw-r--r--app-crypt/qca/qca-1.0.ebuild6
3 files changed, 14 insertions, 3 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 85692fe0484e..2e647328237d 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.7 2005/01/04 15:57:41 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.8 2005/01/06 01:34:03 eradicator Exp $
+
+ 05 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org> qca-1.0-r1.ebuild,
+ qca-1.0.ebuild:
+ multilib fixes.
*qca-1.0-r1 (04 Jan 2005)
diff --git a/app-crypt/qca/qca-1.0-r1.ebuild b/app-crypt/qca/qca-1.0-r1.ebuild
index f65a47f2c5c4..26bdf7223a48 100644
--- a/app-crypt/qca/qca-1.0-r1.ebuild
+++ b/app-crypt/qca/qca-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r1.ebuild,v 1.1 2005/01/04 15:57:41 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r1.ebuild,v 1.2 2005/01/06 01:34:03 eradicator Exp $
inherit eutils
@@ -33,4 +33,7 @@ src_compile() {
src_install() {
make INSTALL_ROOT="${D}" install || die "make install failed"
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
}
diff --git a/app-crypt/qca/qca-1.0.ebuild b/app-crypt/qca/qca-1.0.ebuild
index 740e4807c47f..ace1d7cd03eb 100644
--- a/app-crypt/qca/qca-1.0.ebuild
+++ b/app-crypt/qca/qca-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0.ebuild,v 1.5 2005/01/01 12:37:13 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0.ebuild,v 1.6 2005/01/06 01:34:03 eradicator Exp $
inherit eutils
@@ -33,4 +33,8 @@ src_compile() {
src_install() {
make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
}