summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-07-27 19:14:20 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-07-27 19:14:20 +0000
commit2d27d471550cda4c48fdc61370401444f1299a41 (patch)
treef60296225e80a6efde16c93cdc96444a607cd172 /app-crypt/qca/qca-1.0-r2.ebuild
parent QA: Get rid of deprecated qt_min_version(). Quoting issues. (diff)
downloadgentoo-2-2d27d471550cda4c48fdc61370401444f1299a41.tar.gz
gentoo-2-2d27d471550cda4c48fdc61370401444f1299a41.tar.bz2
gentoo-2-2d27d471550cda4c48fdc61370401444f1299a41.zip
QA: Get rid of deprecated qt_min_version(). Quoting issues.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-crypt/qca/qca-1.0-r2.ebuild')
-rw-r--r--app-crypt/qca/qca-1.0-r2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-crypt/qca/qca-1.0-r2.ebuild b/app-crypt/qca/qca-1.0-r2.ebuild
index 3a06210b270f..08738ff33029 100644
--- a/app-crypt/qca/qca-1.0-r2.ebuild
+++ b/app-crypt/qca/qca-1.0-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r2.ebuild,v 1.18 2008/03/05 23:52:38 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r2.ebuild,v 1.19 2008/07/27 19:14:20 carlo Exp $
+
+EAPI=1
inherit eutils qt3
@@ -13,14 +15,14 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="$(qt_min_version 3.3.0)"
+DEPEND="x11-libs/qt:3"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/qca-pathfix.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/qca-pathfix.patch
#This is needed just in bsd, but make no harm in linux
- epatch ${FILESDIR}/qca-1.0-fbsd.patch
+ epatch "${FILESDIR}"/qca-1.0-fbsd.patch
}
src_compile() {
@@ -36,6 +38,6 @@ src_compile() {
src_install() {
make INSTALL_ROOT="${D}" install || die "make install failed"
if [ "$(get_libdir)" != "lib" ]; then
- mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ mv "${D}"/usr/lib "${D}"/usr/$(get_libdir)
fi
}