summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-24 22:01:43 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-24 22:01:43 +0000
commit49b043101c5302a7065b5135280e45524003f067 (patch)
treeac25fae3706ff51111510480cb026b2eada5e620 /app-crypt/gnupg
parentadded use flag for x11-libs/fltk (diff)
downloadgentoo-2-49b043101c5302a7065b5135280e45524003f067.tar.gz
gentoo-2-49b043101c5302a7065b5135280e45524003f067.tar.bz2
gentoo-2-49b043101c5302a7065b5135280e45524003f067.zip
Move fperms from src_compile to src_install. Normalize to u+s,go-r
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/ChangeLog7
-rw-r--r--app-crypt/gnupg/gnupg-1.4.0-r1.ebuild9
-rw-r--r--app-crypt/gnupg/gnupg-1.4.0-r2.ebuild9
-rw-r--r--app-crypt/gnupg/gnupg-1.4.1-r1.ebuild4
-rw-r--r--app-crypt/gnupg/gnupg-1.4.1.ebuild4
-rw-r--r--app-crypt/gnupg/gnupg-1.9.14.ebuild4
-rw-r--r--app-crypt/gnupg/gnupg-1.9.15-r1.ebuild4
-rw-r--r--app-crypt/gnupg/gnupg-1.9.15.ebuild4
8 files changed, 25 insertions, 20 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index ac3aa1458f6f..17c59491d5db 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.117 2005/06/17 17:32:19 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.118 2005/06/24 22:01:43 agriffis Exp $
+
+ 24 Jun 2005; Aron Griffis <agriffis@gentoo.org> gnupg-1.4.0-r1.ebuild,
+ gnupg-1.4.0-r2.ebuild, gnupg-1.4.1.ebuild, gnupg-1.4.1-r1.ebuild,
+ gnupg-1.9.14.ebuild, gnupg-1.9.15.ebuild, gnupg-1.9.15-r1.ebuild:
+ Move fperms from src_compile to src_install. Normalize to u+s,go-r
*gnupg-1.4.1-r1 (17 Jun 2005)
diff --git a/app-crypt/gnupg/gnupg-1.4.0-r1.ebuild b/app-crypt/gnupg/gnupg-1.4.0-r1.ebuild
index 6b8025dd0524..0143e5ec140b 100644
--- a/app-crypt/gnupg/gnupg-1.4.0-r1.ebuild
+++ b/app-crypt/gnupg/gnupg-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.0-r1.ebuild,v 1.5 2005/01/27 19:36:15 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.0-r1.ebuild,v 1.6 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -109,14 +109,15 @@ src_compile() {
${myconf} || die
emake || die
- if ! use caps ; then
- fperms u+s /usr/bin/gpg
- fi
+ # NOTE libexecdir dir is deliberately different from that in the install
}
src_install() {
emake DESTDIR=${D} libexecdir="/usr/libexec/gnupg" install || die
+ # caps support makes life easier
+ use caps || fperms u+s,go-r /usr/bin/gpg
+
# keep the documentation in /usr/share/doc/...
rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
diff --git a/app-crypt/gnupg/gnupg-1.4.0-r2.ebuild b/app-crypt/gnupg/gnupg-1.4.0-r2.ebuild
index 69a4ac094edb..637fe9105485 100644
--- a/app-crypt/gnupg/gnupg-1.4.0-r2.ebuild
+++ b/app-crypt/gnupg/gnupg-1.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.0-r2.ebuild,v 1.4 2005/03/15 18:11:10 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.0-r2.ebuild,v 1.5 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -113,15 +113,14 @@ src_compile() {
emake || die
# NOTE libexecdir dir is deliberately different from that in the install
-
- if ! use caps ; then
- fperms u+s /usr/bin/gpg
- fi
}
src_install() {
emake DESTDIR=${D} libexecdir="/usr/libexec/gnupg" install || die
+ # caps support makes life easier
+ use caps || fperms u+s,go-r /usr/bin/gpg
+
# keep the documentation in /usr/share/doc/...
rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
diff --git a/app-crypt/gnupg/gnupg-1.4.1-r1.ebuild b/app-crypt/gnupg/gnupg-1.4.1-r1.ebuild
index 861ef3dd7a2f..9352a0d732a5 100644
--- a/app-crypt/gnupg/gnupg-1.4.1-r1.ebuild
+++ b/app-crypt/gnupg/gnupg-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.1-r1.ebuild,v 1.1 2005/06/17 17:32:19 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.1-r1.ebuild,v 1.2 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -125,7 +125,7 @@ src_install() {
emake DESTDIR=${D} libexecdir="/usr/libexec/gnupg" install || die
# caps support makes life easier
- use caps || fperms u+s /usr/bin/gpg
+ use caps || fperms u+s,go-r /usr/bin/gpg
# keep the documentation in /usr/share/doc/...
rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
diff --git a/app-crypt/gnupg/gnupg-1.4.1.ebuild b/app-crypt/gnupg/gnupg-1.4.1.ebuild
index 86c6f2e294c8..919bf106a5f3 100644
--- a/app-crypt/gnupg/gnupg-1.4.1.ebuild
+++ b/app-crypt/gnupg/gnupg-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.1.ebuild,v 1.13 2005/04/06 17:48:02 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.4.1.ebuild,v 1.14 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -123,7 +123,7 @@ src_install() {
emake DESTDIR=${D} libexecdir="/usr/libexec/gnupg" install || die
# caps support makes life easier
- use caps || fperms u+s /usr/bin/gpg
+ use caps || fperms u+s,go-r /usr/bin/gpg
# keep the documentation in /usr/share/doc/...
rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
diff --git a/app-crypt/gnupg/gnupg-1.9.14.ebuild b/app-crypt/gnupg/gnupg-1.9.14.ebuild
index bdfdf8ec249b..18a1b8e6ec75 100644
--- a/app-crypt/gnupg/gnupg-1.9.14.ebuild
+++ b/app-crypt/gnupg/gnupg-1.9.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.14.ebuild,v 1.6 2005/01/27 18:55:06 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.14.ebuild,v 1.7 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -86,7 +86,7 @@ src_install() {
dodoc ChangeLog INSTALL NEWS README THANKS TODO VERSION
if ! use caps ; then
- fperms u+s /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg2
fi
}
diff --git a/app-crypt/gnupg/gnupg-1.9.15-r1.ebuild b/app-crypt/gnupg/gnupg-1.9.15-r1.ebuild
index b782731fa67f..6d7726e4f3e7 100644
--- a/app-crypt/gnupg/gnupg-1.9.15-r1.ebuild
+++ b/app-crypt/gnupg/gnupg-1.9.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.15-r1.ebuild,v 1.1 2005/03/24 10:11:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.15-r1.ebuild,v 1.2 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -88,7 +88,7 @@ src_install() {
dodoc ChangeLog INSTALL NEWS README THANKS TODO VERSION
if ! use caps ; then
- fperms u+s /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg2
fi
}
diff --git a/app-crypt/gnupg/gnupg-1.9.15.ebuild b/app-crypt/gnupg/gnupg-1.9.15.ebuild
index aebc0a54b255..a07da301bb97 100644
--- a/app-crypt/gnupg/gnupg-1.9.15.ebuild
+++ b/app-crypt/gnupg/gnupg-1.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.15.ebuild,v 1.2 2005/01/27 18:55:06 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.15.ebuild,v 1.3 2005/06/24 22:01:43 agriffis Exp $
inherit eutils flag-o-matic
@@ -91,7 +91,7 @@ src_install() {
dodoc ChangeLog INSTALL NEWS README THANKS TODO VERSION
if ! use caps ; then
- fperms u+s /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg2
fi
}