summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-17 04:18:40 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-17 04:18:40 +0000
commit9e0e33e534839f3f84082c344c4cff709028ec9d (patch)
treeb842bbda117f261601e34e635bbc0352325d5674 /app-cdr
parentVersion bump, adds support for hard disk images and Apple .SMI (NDIF) images ... (diff)
downloadgentoo-2-9e0e33e534839f3f84082c344c4cff709028ec9d.tar.gz
gentoo-2-9e0e33e534839f3f84082c344c4cff709028ec9d.tar.bz2
gentoo-2-9e0e33e534839f3f84082c344c4cff709028ec9d.zip
Version bump, adds support for non-blocking I/O and device addition/removal (bug #472784, thanks to Henrik Stokseth and Rafał Mużyło).
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemu-daemon/ChangeLog10
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-2.1.0.ebuild46
-rw-r--r--app-cdr/cdemu-daemon/files/cdemu-daemon-2.1.0-DISABLE_DEPRECATED.patch35
3 files changed, 90 insertions, 1 deletions
diff --git a/app-cdr/cdemu-daemon/ChangeLog b/app-cdr/cdemu-daemon/ChangeLog
index 8fbd280d37bb..740810b2f51e 100644
--- a/app-cdr/cdemu-daemon/ChangeLog
+++ b/app-cdr/cdemu-daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-cdr/cdemu-daemon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu-daemon/ChangeLog,v 1.1 2013/01/28 00:22:03 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu-daemon/ChangeLog,v 1.2 2013/06/17 04:18:40 tetromino Exp $
+
+*cdemu-daemon-2.1.0 (17 Jun 2013)
+
+ 17 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +cdemu-daemon-2.1.0.ebuild,
+ +files/cdemu-daemon-2.1.0-DISABLE_DEPRECATED.patch:
+ Version bump, adds support for non-blocking I/O and device addition/removal
+ (bug #472784, thanks to Henrik Stokseth and Rafał Mużyło).
*cdemu-daemon-2.0.0 (28 Jan 2013)
*cdemu-daemon-1.5.0 (28 Jan 2013)
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-2.1.0.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-2.1.0.ebuild
new file mode 100644
index 000000000000..085613c99c78
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu-daemon/cdemu-daemon-2.1.0.ebuild,v 1.1 2013/06/17 04:18:40 tetromino Exp $
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/5" # subslot = CDEMU_DAEMON_INTERFACE_VERSION in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS README"
+ PATCHES=( "${FILESDIR}/${P}-DISABLE_DEPRECATED.patch" )
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
+ fi
+}
diff --git a/app-cdr/cdemu-daemon/files/cdemu-daemon-2.1.0-DISABLE_DEPRECATED.patch b/app-cdr/cdemu-daemon/files/cdemu-daemon-2.1.0-DISABLE_DEPRECATED.patch
new file mode 100644
index 000000000000..399bb59cbf77
--- /dev/null
+++ b/app-cdr/cdemu-daemon/files/cdemu-daemon-2.1.0-DISABLE_DEPRECATED.patch
@@ -0,0 +1,35 @@
+From 0d9ce2618014c41b5aefce8355af95b0d1119d85 Mon Sep 17 00:00:00 2001
+From: Henrik Stokseth <hstokset@users.sourceforge.net>
+Date: Mon, 10 Jun 2013 03:42:49 +0200
+Subject: [PATCH] All: Stop defining G_DISABLE_DEPRECATED.
+
+Defining G_DISABLE_DEPRECATED is a bad idea. For one it means deprecated
+functions etc. is effectively removed by the preprocessor. This breaks
+compilation on certain setups (read: Launchpad compiler farm), since
+the functions are not declared and therefore you get warnings about
+the calls being implicit. And on setups that compiles the code, the
+resulting code might result in undefined behaviour, in particular on
+64-bit platforms.
+
+Note that on supported compilers such as GCC, you will still get warnings
+about calling deprecated functions without this define in place.
+---
+ cdemu-daemon/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cdemu-daemon/CMakeLists.txt b/cdemu-daemon/CMakeLists.txt
+index 1320266..11e6b33 100644
+--- a/cdemu-daemon/CMakeLists.txt
++++ b/cdemu-daemon/CMakeLists.txt
+@@ -49,7 +49,7 @@ configure_file (
+
+ # Global definitions
+ add_definitions (-std=gnu99) #NOTE: Compilation bugs out on using signals and -std=c99
+-add_definitions (-DHAVE_CONFIG_H -DG_DISABLE_DEPRECATED)
++add_definitions (-DHAVE_CONFIG_H)
+
+ if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions (-Wall -Wextra -Wshadow -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align)
+--
+1.8.2.1
+